1
$\begingroup$

I recently updated my Creality Sonic Pad to v1.0.6.49.145 (June 28, 2023 release) and since I applied that update, I've been consistently receiving the error when attempting to print any G-code file:

Error Message:
Unable to parse move 'G1 X251.931 Y187.6.324 E35.93675'

Screenshot of error message on the Creality Sonic Pad

(The coordinates in the error message above change based on the model I'm attempting to print, I've just added these for reference.)

The printer just freezes in place after completing line two and does not advance, then briefly throws this error on the screen. (I had to sit and watch it because the error only appears on screen for about 5 seconds.)

It doesn't matter what model or slicer (Cura or Creality Slicer) I use to create the file, I still get the message. I also receive the message on any files that I successfully printed before the update and have tried to re-print as a test.

For reference, I'm running:

  • Printer: Creality Ender V3 Max Neo
  • Slicers: Ultimaker Cura 5.4.0 and Creality Slicer 4.8.2
  • macOS Monterey 12.3
  • Models transferred via USB drive and Moonraker.

Any ideas on how to get past this error?

$\endgroup$
3
  • $\begingroup$ I don't have enough rep on this exchange to create a tag yet, but a Sonic Pad tag would be really nice to add, if someone has the rep -- so I've just added the Klipper tag for now. $\endgroup$
    – user37619
    Aug 14, 2023 at 17:11
  • 1
    $\begingroup$ The changes I made are within the guidelines of the site. $\endgroup$
    – agarza
    Sep 2, 2023 at 17:27
  • $\begingroup$ @stevegomez - Post locked - Please note that neither "rollback wars" nor destructive behaviour will be tolerated. Once you post content, it becomes public, due to the terms and conditions that you agreed to - see this answer. WRT to the edits made to your post, please see also Useful things to check for when cleaning up posts. Thanks. $\endgroup$
    – Greenonline
    Sep 2, 2023 at 22:04

2 Answers 2

1
$\begingroup$

I have had this problem ever since I have had the sonic pad, I found that I just go straight back to print & start print again , it just restarts where it stopped.

$\endgroup$
0
$\begingroup$

Not a fix, but a workaround for anyone else experiencing this issue. I was able to get past it by changing my upload format from "G-code" to "UFP with Thumbnail" in my Cura Moonraker settings. After this change I have been able to print with no problems and I have not gone back and attempted to transfer straight gcode files. (Because I like the thumbnail previews showing on the Sonic Pad. 😎)

You can get to this screen in Cura by clicking the top menu:
Settings > Printer > Manage Printers...

On the "Preferences" dialog click:
Printers > Preset Printers > Your printer's name > Connect Moonraker > Upload

Screenshot of the 'Connect Moonraker' in the Printers setting in Cura

$\endgroup$

You must log in to answer this question.