1
$\begingroup$

I have an Ender 3 Pro, board version 4.2.2, and a CR Touch with 5 pin connector. I also removed the z-axis endstop connector at the endstop.

I've been building and flashing Marlin 2.1.2.2, but I haven't found a configuration that makes the CRTouch work as expected. Typically, during auto homing, the machine will ignore the probe triggering and drive Z into the bed either 100% of the time or most of the time. I didn't take detailed enough notes to know for sure.

As a test case, I tried following along with this answer exactly and still had the same problem. Configuration changes from the Marlin Ender 3 Pro default:

  • Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN commented out
  • USE_PROBE_FOR_Z_HOMING uncommented
  • Z_MIN_PROBE_PIN uncommented and set to PB1
  • BLTOUCH uncommented
  • NOZZLE_TO_PROBE_OFFSET set to { -44, -9, -0.9 } (here I differ slightly from the { -44, -9, 0 } in the answer)
  • AUTO_BED_LEVELING_UBL uncommented
  • ENABLE_LEVELING_AFTER_G28 uncommented
  • Z_SAFE_HOMING uncommented (not in the answer, but in a comment)

On my first boot after inserting the SD card with firmware:

  1. The probe deployed and retracted a couple of times, ending retracted with the red LED on
  2. The machine seemingly flashed the firmware as it sat on a blue screen for a while
  3. The CRTouch LED turned purple I think when flashing ended, though I can't tell from my video
  4. When I got to the main menu, I started auto homing
  5. X and Y axes worked as expected
  6. For the Z axis, the probe centered on the build plate, deployed, and the LED turned blue
  7. The probe started lowering, contacted the plate and retracted. The LED turned to blinking red, maybe steady red first. The Z motor kept driving down so I killed the power

The extruder fan also made a loud buzzing noise that gradually grew quieter. In the past I've noticed the buzzing seemingly get quieter when the probe is deployed or retracted.

Anyone know what could be causing this, or how to troubleshoot it? Creality's firmware works as expected, so it's not a hardware problem. I was thinking maybe PB1 is wrong for the Ender 3 Pro, but from what I see online I gather it's the same mainboard between both printers.

$\endgroup$
4
  • $\begingroup$ You modified the hardware in a degree that it does not match the original hardware expected by the firmware. Of course you need a custom firmware now. The Z-Probe isn't a simple toggle though. $\endgroup$
    – Trish
    Feb 15 at 13:44
  • $\begingroup$ @Trish I'm not expecting stock Marlin to work. My question is what I need to play around with in my configuration to get the expected behavior, as miming someone with presumably the same hardware configuration isn't working $\endgroup$
    – ttshaw1
    Feb 15 at 16:54
  • $\begingroup$ Ahhh! So the question is basically "How do I properly enable the BL touch in Marlin 2.1.2.2 using the ender3 chip? We might need to know the exact model of sensor. $\endgroup$
    – Trish
    Feb 15 at 17:08
  • $\begingroup$ @Trish It's a CR Touch, not a BL Touch. I'm not aware of there being more than one model of the CR Touch $\endgroup$
    – ttshaw1
    Feb 16 at 0:39

2 Answers 2

2
$\begingroup$

I think this is an issue with Marlin v2.1.2.2, which I was trying to use. https://github.com/MarlinFirmware/Marlin/issues/26809 this issue points to another bug with probing. My issue is different, but downgrading to 2.1.1 solved it.

$\endgroup$
0
$\begingroup$

I also have an ender 3 pro that I added a bl touch to. I set mine up with removing the z limit switch and connecting the bl touch using those pins along with the z probe pins. You need to verify which board you have (probably a v4.2.2) and which cpu is on your board,mine was STM32F103 RET6 CPU there are some using a different model. I was never able to get marlin to build and work with the bl touch, however I was able to flash https://github.com/zisismaras/ender_3_4.2.2_firmware which worked fine. A 4.2.2 board with the RET6 cpu is required. You / someone could do a config side by side and figure out which flag(s) you are missing in your configuration or you could just flash whichever probe grid you are comfortable with and use these auto builds.

$\endgroup$
2
  • $\begingroup$ I've got the RET6, luckily, so this should work for me. I'll give it a shot in the next couple of days; if this pre-built image works then I'll figure out what's missing in my config. Thanks! $\endgroup$
    – ttshaw1
    Feb 16 at 0:40
  • $\begingroup$ Well, the 5x5 auto probe firmware didn't work. I verified that Creality's firmware is working as expected; I'll have to see if I can get them to fork over their source code so I can figure out what they're doing differently $\endgroup$
    – ttshaw1
    Feb 17 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .