1
$\begingroup$

I have a problem with the infill settings of a solid cube. I have 0 top and bottom layers, wall counts (zero), and infill set at 100 %. The infill line directions are [90, 90].

However, I have an issue with the starting position of the infill line. After the first layer, the infill line starts from the middle (orange in the picture) of the print rather than starting from the edge. What can I change so that every infill line in each layer starts from the same position? I have attached my project file. Please give me some suggestions.

enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

What can I change so that every infill line in each layer starts from the same position?

With the current slicers probably nothing, but this may depend on the slicer you are using, it is not specified. Generally, you cannot define the order of printing of the infill from the settings. This may require you to dive into the open source code of slicers to get this done.

However, being a basic cube, you could write your own G-code file. E.g. if you are able to use python, you could create a simple program to generate the G-code for you. Alternative is to manually copy paste each layer in a notepad editor using the correct G-codes to make sure the extruder length is reset at the start of each layer. The latter option shouldn't be that difficult to do, but, this only works for simple geometries. Otherwise you would be developing a completely new slicer.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .