8
$\begingroup$

I have an M3D Micro 3D printer that printed fine for a couple of weeks and then was plagued with issues afterward. I've done the fixes from the forum to get proper heating and cooling of the nozzle (I've added aluminum foil around the nozzle to make sure the hotend is fit snug against the nozzle and I've added an external fan, powered externally, to compensate for heat creep).

This works very well for short prints and it usually finishes successfully. When I do a longer print it always stops midway and usually at the same exact point.

I tried printing at 200 °C with black PLA and then again at 215 °C with the same filament and it stops at the same exact point. I also tried M3D brand white filament. I am using CURA slicer with Octoprint GCODE sender and M3D Fio.

I know it is not clogged because if I stop the print and press extrude without letting it cool down, it extrudes fine.

What is causing my printer to stop printing?

$\endgroup$
  • $\begingroup$ does this happen with different models or the same model each time? Are you able to use an alternative means to present the g-code to the printer, such as an SD card or direct USB cable from the slicer software? If there is a communications problem with Octoprint, the above steps will help to isolate it. $\endgroup$ – fred_dot_u Sep 17 '16 at 23:36
  • $\begingroup$ I started to try repetier host to send the gCode over, but I cannot get it to run on my system it starts up and crashes immediately. Also, in order to use anything else, I will have to reflash the printer's firmware to an open source version. Can you recommend a good gCode sender for Linux machines? $\endgroup$ – Aaron Cofield Sep 18 '16 at 18:32
  • $\begingroup$ It's not a gcode sender specifically but I would be surprised if it would exclude such capability, try Craftware. A quick visit to their home page shows there is a linux installer for the program. It's currently in Beta stage, per the web site craftunique.com/craftware but it has received good reviews from various 3d printer locations. $\endgroup$ – fred_dot_u Sep 18 '16 at 18:35
  • $\begingroup$ I have one that has a bad extrusion motor that the extruder starts and stops. I took it apart and could feel the motor slipping when I told it to load filament. I thought it was a heating problem too until I put the micro + kit on and it still had the same problem. $\endgroup$ – Biggg Ben Dec 26 '18 at 4:03
  • $\begingroup$ @BigggBen I have tried replacing the extruder motor in my machine, but the same issue still presents. Has the micro + kit improved performance? $\endgroup$ – Aaron Cofield Dec 27 '18 at 18:55
2
$\begingroup$

I'm not sure how similar the two systems are, but I use a Stratasys uPrint SE Plus and I've run into a similar problem.

There are two rollers in the head that pull the filament through to the extruder nozzle, and in one instance they appeared to have heated up, melted the filament enough to create two "indentions" on either side of the filament, making it such that the rollers had no purchase on the filament itself. There was never any clog, no material feed error, but it was still failing to print. Wound up having to replace the head altogether.

Again, not sure how similar the extrusion mechanics are in the M3D, but suggest checking the components that actually advance the filament, and the filament itself.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Placing this suggestion as an answer, because all information appears to point to the slicer software and/or the operating system. Consider to use alternative methods of slicing and sending the model, such as the previously mentioned Craftware or other free slicers, such as Slic3r - both of which have Linux versions. If, as you suggest, your firmware is so tied down that it won't run alternate versions without re-flashing, that would be your next step. Unfetter yourself from the limitations of the current suspect software.

If you are able to use other slicers and discover that the problem remains, the re-flashing of the firmware is likely the only solution.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.