Repetier host 1.6.2. Used Slic3r and CuraEngine in RH1.6.2 to slice my prints.

OK, I've a problem.. Z offset does not work.. Well..

  1. Flashed EEPROM clear.
  2. Enabled EEPROM and CHIT CHAT within firmware.
  3. I've set -0.4 in Marlin firmware 1.0.2-1 stable and flashed it.

G28; home axis = works G29; auto level = works G28; it goes to home and then sets Z to 0.4 G1 Z0; brings nozzle down from 0.4 to 0, so this works also.

But when I slice with Repetier host 1.6.2 with latest slicer / curaengine, it does not go down 0.4 mm before starting to print. I've set first layer to 0.2mm, but when it starts printing the first layer, it goes from 0.4 (after home Z is on 0.4) to 0.6 instead of 0.2! ...

How to fix this?

Gcode start: ;Generated with Cura_SteamEngine 15.01 ; Default start code G28 ; Home extruder G29 ; Auto level G1 Z15 F100 M107 ; Turn off fan G90 ; Absolute positioning M82 ; Extruder in absolute mode M190 S35 ; Activate all used extruder M104 T0 S230 G92 E0 ; Reset extruder position ; Wait for all used extruders to reach temperature M109 T0 S230 ;Layer count: 226

UPDATE: It's definitely Repetier or it's slicers. I'm using Cura 15.04.6 and it also calculates the offset set in marlin when printing! I'm trying to use Cura 2.1 because it's newer, but I do not get the print usb option in Cura 2.1 :/

UPDATE 2: I just don't get it, it was printing very nice the first 4 layers, and suddenly it moved up more than 0.5mm and continued printing there, in the air.

UPDATE 3: I really don't get it. Yesterday: enter image description here enter image description here

Today: enter image description here


1 Answer 1


Your question is a little hard to pin down, but I'll try to help anyway. :-)


  • It appears you may be misunderstanding the way z-offset is supposed to work especially when it comes to Marlin setup and routine bed leveling and printing.
  • This may help.
  • And this

Print Quality and Skipped layer issues:

From your pictures, you do have some loose or wobbly belts, pulleys, rails, or other mechanical components causing excessive play in your x and y axis...very apparent with the way your layers don't align well resulting in the very visible lines. You can address this in two ways:

  • Make sure your physical components are tight and rigid enough to handle the print speed you're using.
  • Slow down your print speed to something that your machine can handle with reasonable quality...whatever reasonable is for you.

You mentioned skipped layers. I see that in your tower. This is most likely caused by:

  • Tower legs too thin so Cura skips it because it can't fit there. I'd suggest using the layer preview in Cura, if the layer doesn't show in the preview, it won't print. If this is because the leg is too thin for your nozzle diameter, you could increase the scale of the tower, edit the model to have thicker legs, or install a finer nozzle.
  • Issues with your mesh so Cura skips it. Also use Cura's x-ray view. If there are red areas, you have issues with your mesh. Search for ways to fix your mesh and make sure your model is good to print.

However, it could also be caused by issues with your filament feeding or your hot end. Clogs, snags, etc. If this were the case, your previews in Cura would all be fine. To solve this you could:

  • Increase your print temperature slightly to ensure you're filament is melting quickly enough to support your print speed.
  • Slow down to allow the filament plenty of time to melt.
  • Make sure your feed system is snag-free.
  • Make sure your feed system is clean and adequately gripping the filament so it can push the filament into your hot end reliably.

I hope this helps. :-)

  • $\begingroup$ Also looks like it went a bit fast on the upper part of the Eiffel Tower, increasing minimum layer time might help a bit. $\endgroup$
    – Pelle
    Oct 11, 2016 at 6:26
  • $\begingroup$ Hi! Thanks for helping me out. I have had few good prints, but then it randomly starts printing bad. When I enter the Z offset in the Marlin code to -0.5, it doesn't go down 0.5mm when starting the first layer. It stays at the same height, which is 0.5mm above the bed. So Z offset doesn't work trough the Marlin code. Then I tried Z offset in Repetier and the same happens. Does not lower. When setting Z offset to 0 in Marlin, and then adding G92 Z0.5 in the GCODE, it lowers the model in the slicer, so 0.5mm of the part goes into the ground. But adding that to the Gcode, lowers my nozzle to..... $\endgroup$ Oct 11, 2016 at 13:24
  • $\begingroup$ ... the right height, which is one paper height between the bed and nozzle. The prints turn out better this way. I have figured out some lose parts which I will tighten up soon and test it out again. The legs of the eiffel tower do show normally in the slicer. I managed to print again with my printer, but now with really small layer shifts (which is because of lose parts I guess), and some missing outer layers (like it did not feed enough filament at that moment.). Increasing filament feed rate from 100 to 130 and increasing the temp from 220 to 230 fixed this problem a little bit, but... $\endgroup$ Oct 11, 2016 at 13:27
  • $\begingroup$ Still missing outer layers every few mm heights. maybe this is also caused by little movements in the components? Going above 230, e.g. 235, the filament feeds really hard. I thing it's too hot for the plastic housing inside the extruder hot end, or the filament just gets burnt or something. ... So my question, why does Z offset not work when adding in Marlin code, or slicer? I will update here if the quality improves after making everything stable. Thanks again $\endgroup$ Oct 11, 2016 at 13:30
  • $\begingroup$ "randomly starts printing bad"...yeah, I know it can seem that way sometimes. There are many many variables that sometimes play together in mysterious ways. $\endgroup$ Oct 11, 2016 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .