7
$\begingroup$

I have a strange problem with my Printrbot Simple Metal.

When I start printing it's suddenly trying to go off axis before starting to print. All is fine once it actually starts to print, but it's very annoying to hear the sound on the start and end of each print.

That can't be good on the motors and chains either, something is going to give out at some point.

Here's what that sounds like: YouTube - IMG 5600.

My OctoPi settings are:

OctoPi settings

$\endgroup$
4
$\begingroup$

It is very common that FDM 3D printers "home" their position at the start of each print (as defined by the slicers preprint g-code). This is done by deliberately running the end effector towards its expected X=0, Y=0 position until it hits the endstop switches for each axis. Could it be this behaviour you are seeing? If so, I would suggest checking that your endstops are functioning correctly.

You can manually activate this homing action using the G-code G28 in (for instance) Pronterface. Alternatively, you can verify that your endstops are actually working using the M119-command while pressing each switch manually.

$\endgroup$
13
  • 1
    $\begingroup$ Could the axis get inverted somehow? Because instead of taking it all the way to the stop, it's taking it in the opposite direction when it starts? $\endgroup$
    – R0b0tn1k
    Oct 25 '16 at 15:16
  • $\begingroup$ Just found something. I was reconfiguring the Z leveling, and it's changed the behavior a bit. Now the X axis is doing the screeching, even though it's not gone off chart? $\endgroup$
    – R0b0tn1k
    Oct 25 '16 at 15:17
  • $\begingroup$ If you axes are going reveresed, the that certainly is something you should fix! :-) However, when you say "screeching", do you still mean the sound in the video, or just a high-pitched sound from when the motors are powered and standing still? In general, as long as stepper motors are powered (that is, they resist movement if you try to move them manually), they will often make a high pitched noise. You can try to run M18 to disable all stepper motors, and see it that helps. $\endgroup$ Oct 27 '16 at 7:22
  • 1
    $\begingroup$ It's definitely a part of the homing command.. $\endgroup$
    – R0b0tn1k
    Nov 5 '16 at 20:58
  • 1
    $\begingroup$ @R0b0tn1k lag can come physically and digitally. Physical lag (although unlikely) can come from excessively long cables (USB, RJ45, etc). Digital lag can come from a number of sources. Double check that you have the minimum set of applications running in the background. Try to free up CPU and RAM usage as much as possible. Are you running true OctoPi or just OctoPrint on a PC? $\endgroup$
    – tbm0115
    Dec 5 '16 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.