I am running crazy trying to install Slic3r on my Kubuntu 14.04. It is a fresh Kubuntu and I downloaded the Slic3r package from them.

At first it worked well but then I changed the display driver to NVIDIA instead of the default Nouveau. I have repeated this operation a couple of times and I am almost sure that the NVIDIA driver screws up my system.

I have read and followed several "SOLVED" posts but none of them gave me a solution.

Any ideas?

  • $\begingroup$ Is this really a suitable question for this site? It's only marginally 3D printing related, and might be more suitable for a place where they deal with troubleshooting Ubuntu drivers. $\endgroup$ – Tom van der Zanden Nov 13 '16 at 9:16
  • 1
    $\begingroup$ I am having this problem only with this application, which is mostly used in the 3D Printing world. This is the reason why I ask here this question. There may be some other member having faced the same problem with this application. $\endgroup$ – Luis Rosety Nov 13 '16 at 14:44
  • $\begingroup$ Does the command line functionality of Slic3r work? $\endgroup$ – Eric Johnson Jan 4 '17 at 3:04
  • $\begingroup$ I have upgraded to Kubuntu 16.04 and it works after git cloning it. $\endgroup$ – Luis Rosety Jan 5 '17 at 20:35

There is a huge problem with any linux distributions and Nvidia drivers. I have tried countless times to get that driver to work but it crashed my systems time after time. If your slicer works with the default driver i would not try to change it. If it doesn't then you may have to go to windows where the driver is guaranteed to work. I know this is not the answer you are looking for but unless you can code a new driver to work for Linux thats the only solution.

  • $\begingroup$ Yes John! Unfortunately I got the same conclusion after so many trial and error tests. Surprisingly Cura seems to work so far and I'm sticking to it. $\endgroup$ – Luis Rosety Apr 18 '17 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.