6
$\begingroup$

Like many people, I have burnt the pins in the micro-controller connected to the E0 motor - the E0 motor is not working anymore and I need to print tomorrow! I need to control the extruder motor with the working E1 pins. How do I change this in firmware?

I tried to change to the pins in `pins_RAMPS.h" but it was a complete fail, the motors that i tried to change didn't move.

I have a Arduino Mega + Ramps 1.3 in "Extruder Fan Bed" configuration, I use Repetier-Host as host and Marlin as firmware.

$\endgroup$
  • 3
    $\begingroup$ How did you find that Arduino pins were burnt? Have you tried spare motor driver? $\endgroup$ – Mikhail Z Dec 12 '16 at 18:30
  • $\begingroup$ @MikhailZ Yes definitely ! I swapt the drivers to test them, and I always replace the bad drivers with new/repaired ones. $\endgroup$ – masterleo Jan 25 '17 at 21:23
  • $\begingroup$ Changing pins_RAMPS should work. You must have done something wrong when trying it. $\endgroup$ – Tom van der Zanden Feb 10 '17 at 12:34
  • $\begingroup$ To elaborate on this answer of Thomas S, a more detailed description of swapping the pins is found in this 3D.SE answer. Please vote and accept an answer (we want this community to get out of Beta stage), thanks! $\endgroup$ – 0scar Aug 3 '18 at 19:15
5
$\begingroup$

I would change the pin assignments by swapping E0 and E1 in pins_RAMPS.h.

$\endgroup$
  • 1
    $\begingroup$ A more detailed answer is found here. $\endgroup$ – 0scar Jul 6 at 3:59
4
$\begingroup$

As a quick and dirty solution you may try to enable two extruders in configuration file, re-upload firmware, and then edit your GCODE file to replace all E0 references with E1.

$\endgroup$
  • $\begingroup$ That's a really good idea. It should be possible to have the firmware do it. Or there must be a script that can be ran... But it doesn't seem this firmware is all that great. I would suggest a different firmware if it doesn't do what is needed. $\endgroup$ – StarWind0 Dec 13 '16 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.