I'm running an OctoPi Raspberry Pi installation of OctoPrint, and the webcam images are too bright.

I found some documentation on changing the exposure of mjpg-streamer, see github:foosel/OctoPrint/MJPG Streamer configuration, but I don't understand where, or how, to change these settings.

  • $\begingroup$ Can you edit your post to include the links to the documentation in your question? $\endgroup$
    – Greenonline
    Dec 23, 2016 at 14:08

1 Answer 1


The commands in your documentation only work with the Raspi camera. If that's the camera you're using, you can use the tools mentioned from terminal on your Raspberry Pi, or over SSH.

If you don't have SSH setup and are using your Raspberry Pi with a keyboard and mouse, you can access the command line by pressing ctrl+alt+f1 remembering that ctrl+alt+f7 brings back your GUI.

Setting exposure for Raspi camera

First navigate to the folder you installed mjpg-streamer. If you installed it in your home folder:

cd ~/mjpg-streamer/mjpg-streamer-experimental

Then use the input_raspicam.so utility to set the exposure using whatever preset you'd like.

./input_raspicam.so -ex night

If you don't have a Raspi camera

I'm currently using a Logitech HD Webcam C310 with OctoPrint. I'm pretty sure setting the exposure for that is a pretty standard operation and you shouldn't need to install anything. v4l2 (video 4 linux 2) comes installed with Raspian.

To set the exposure for a Logitech camera (possibly others too) first enable manual exposure mode (1 for manual, 0 for auto)

v4l2-ctl -c exposure_auto=1

Then set the exposure value with

v4l2-ctl -c exposure_absolute=100

replacing 100 with whatever value you'd like. The values start at 1 and have a maximum value of 10,000.

These commands can of course be run over SSH.

You can also run

v4l2-ctl --list-ctrls-menus

to see all the options for your camera.

Here's a screenshot of my ssh session and my OctoPrint interface for context:

Screenshot of ssh session and OctoPrint interface

  • 1
    $\begingroup$ v4l2-ctl worked very well with my lifecam studio. With my Flashforge Creator Pro, white_balance_temperature=5000 focus_absolute=29 zoom_absolute=0 sharpness=35 looks pretty good! $\endgroup$ Jun 8, 2017 at 6:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .