6
$\begingroup$

This is my problem:

I'm assembling a 3D printer with the RAMPS 1.4 board and Arduino Mega. I have assembled the structure and the electronics (set drivers, placed the jumpers, connected stepper motors...) and have uploaded Marlin firmware (configuring: thermistor, endstops...) on the Arduino Mega.

I've tried to connect, via USB, to the computer and using the Repetier software I have commanded the printer which did do some movement. The printer worked perfectly. After a few tests, however, I've noticed that the Arduino was restarting several times and at one point I saw a component on the Arduino board burning. Searching the internet I saw that the burned component was the voltage regulator.

I heard also about unplugging the screen because it consumes a lot of current, that passes through the voltage regulator, thereby heating it up. I then proceeded to buy another Arduino Mega. I also checked the voltage of my 12V 360W power supply and it is correct. I always powered the Arduino with USB and RAMPS 1.4 was connected to the power supply from the two terminals.

Power Terminals of RAMPS 1.4

When the new Arduino arrived, I connected the whole (without connecting the screen) and tried. The printer worked very well until it started giving the same problem as the first Arduino board. Someone can tell me if I have done something wrong, or is it the RAMPS board that does not work properly?

EDIT:

I read that the endstops can cause this problem. I have these endstops: 1 PZ di Alta Qualità Finecorsa Meccanico Per rampe Reprap 1.4 stampante 3D Con imballaggio indipendente kit fai da te and I connected the black wire to GND, red wire to 5V and the green wire to SIGNAL.

$\endgroup$
  • $\begingroup$ It seem unlikely that the endstops particularly cause this problem. Yes, unplugging the screen will help (but not fix the problem). This seems like a hard problem to diagnose without some experience. With the screen disconnected, your electronics really shouldn't be taking too much power. Maybe it is the stepper motors, these are able to take a lot of power, particularly if there is a mechanical problem. $\endgroup$ – Sean Houlihane Dec 26 '16 at 11:28
  • $\begingroup$ @SeanHoulihane Your last suggestion makes no sense, as the stepper motors are not powered using the 5V regulator. $\endgroup$ – Tom van der Zanden Dec 26 '16 at 11:33
  • $\begingroup$ I wouldn't be so quick to rule out the endstops. Perhaps the connector is backwards, or the black and green wires exchanged, who knows? Maybe try measuring the resistance between 5V and GND (on the RAMPS shield) with the endstops inserted (and triggered/not triggered). $\endgroup$ – Tom van der Zanden Dec 26 '16 at 11:36
  • 2
    $\begingroup$ @Francesco The resistance between 5V and GND being zero is a very bad sign. You hooked up the endstops wrong. $\endgroup$ – Tom van der Zanden Dec 26 '16 at 14:20
  • 1
    $\begingroup$ @Greenonline Yes i've solved. The problem was that the voltage regulator on the Arduino wasn't the original, so it wasn't able to absord too much current. To resolve the problem i unsoldered the diode(D1) on RAMPS board so the Arduino is only powered by the USB and everything works good. $\endgroup$ – Francesco May 26 '17 at 20:51
2
$\begingroup$

I've solved unsoldering the diode(D1) on RAMPS. This diode provides to power the arduino board with 12V. If you have a chinese arduino this will probably cause some problems. enter image description here

I hope this will help someone.

| improve this answer | |
$\endgroup$
2
$\begingroup$

I ordered an authentic Arduino Mega today after the voltage regulator on my Chinese clone Mega went up in smoke. But I couldn't wait two whole days so I dug around and found an old 7805 (less than US$1 new btw) and soldered it in. It worked! Just one more possible solution. Actually that's two if you count buying a real Arduino.7805 on Mega clone board

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.