1
$\begingroup$

I'm having an issue with my new Prusa i3. (This one: https://www.amazon.co.uk/gp/product/B01DLIRDFW/ref=oh_aui_detailpage_o03_s00?ie=UTF8&psc=1)

For some reason the Y and Z axis are swapped when I print Gcode files, even though all the axis move correctly when I manually move them with the interface on the LCD. Also, if I try to print an STL file, the Z axis moves in one direction more than it is actually limited to, and then does the same again in the opposite direction when the print starts.

Anyone know the solutions?

$\endgroup$
1
$\begingroup$

Sounds like your slicing program is not set up right.. Or more likely your printer isn't.

I would use Pronterface

I use simplify 3d, but the best free software is Slic3r.

Try those then report back. Honestly I think you might not have it wired correctly. With pronterface tell it to move X. Then try moving it and manually holding the endstop. Then if it does not stop try going tho incorrect way with that endstop still pressed. If you find that your reversed you will need to correct this with your firmware. If I knew this was a ramps board you could reverse the wires, but lets do it in firmware as I am not buying you a new board.

After that you should work. Software wise we just made sure your interface and your slic3r work and talk the same language. Those two I know will not be doing anything funny. After that report back if it is still not working.

| improve this answer | |
$\endgroup$
  • $\begingroup$ UPDATE I've managed to get it to connect. I'll do a test print now $\endgroup$ – user5397 Dec 28 '16 at 12:18
  • $\begingroup$ Okay, I've managed to get my printer to connect to Pronterface, but the Y and Z axis do not move the correct distance in accordance to what distance I control them to move. For example, if I command the Z axis to move forward by 10mm it moves way further and tries to go over the limit. The Y axis moved too little of a distance. What is causing this? $\endgroup$ – user5397 Dec 28 '16 at 12:33
  • $\begingroup$ @solluu The Z axis generally moves up and down, not forward (or backward). Are you sure you're using the right names for the axes? $\endgroup$ – Tom van der Zanden Dec 28 '16 at 13:25
  • $\begingroup$ That's solved the issue :) Thank you so much for your help! All I need to fix now is a blocked endcap lol. $\endgroup$ – user5397 Dec 28 '16 at 17:04
  • $\begingroup$ Hmm yes I should have included documentation of which direction is which. Glad it is working. $\endgroup$ – StarWind0 Dec 28 '16 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy