2
$\begingroup$

I am calibrating my Kossel XL with a new Marlin firmware changing the MANUAL_Z_HOME_POS since I have modified my print bed.

I change the value in the Marlin code and upload it through Arduino (the editor on Windows 10). It has worked many times before with the exact same version of Arduino.

When I then use Pronterface and issue G28 (home all) followed by G1 Z30 (just to be on the safe side) it shows that Marlin wasn't uploaded at all. It is a the same height as before. It's a 22.2 mm difference so it is easy to see.

  • I have tried restarting the Arduino board before and after upload.
  • I have tried unplugging the USB cable before and after upload.
  • I also tried two different USB ports.
  • The computer has been rebooted.
  • I have examined the Arduino editor's settings, so it uploads to the correct destination (COM3 in my case). It is as it should be. It, of course, reports "upload complete".

What can be the cause of this?

$\endgroup$
  • $\begingroup$ Is it perhaps reading the value from EEPROM instead of from the firmware? $\endgroup$ – Tom van der Zanden Feb 2 '17 at 9:17
  • $\begingroup$ No, I have changed MANUAL_Z_HOME_POS before the same way. $\endgroup$ – Gunslinger Feb 2 '17 at 13:59
3
$\begingroup$

Are you sure that the firmware is not being uploaded? You can debug this changing the STRING_VERSION on Configurations.h. If the version is not being changed, I would suggest trying to use another computer to upload the firmware or even another board.

| improve this answer | |
$\endgroup$
  • $\begingroup$ It may be some trouble with the board, thanks for the tip, will try. $\endgroup$ – Gunslinger Feb 2 '17 at 13:59
  • $\begingroup$ I changed the machine name CUSTOM_MENDEL_NAME and that is shown on the display after I uploaded so I guess there is some other problem. $\endgroup$ – Gunslinger Feb 5 '17 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.