The problem

When I print with my mElephant 3D printer from Makeblock, the prints come out with waved walls like in the picture below. I am using PLA filament from https://makeblock.lt


What I tried

I tried changing temperatures 190-220, tried to change the flow rate. Also checked if the bolts are not lose. Everything seems good.

My printer


  • $\begingroup$ Are the smooth rods held with a screw in the end on both sides? $\endgroup$
    – tjb1
    Feb 9, 2017 at 14:42
  • $\begingroup$ Possible duplicate of Unidentified problem in printing $\endgroup$
    – StarWind0
    Feb 9, 2017 at 16:25
  • $\begingroup$ This issue is a mechanical related issue called "Z wobble". $\endgroup$
    – 0scar
    Jul 24, 2019 at 21:28

6 Answers 6


I had the same problem with ABS, but printing different test objects I found out that the distance between the wavy structures depends on the cross sectional area of the object. Printing the testcube in 70.1% (1/sqrt(2) times of the original size) takes half the time per layer and the distance between two grooves doubles. I was printing ABS with 0.1 mm layer height and the simple bang-bang heat bed controller. The temperature is clearly wandering for 4° with a period of aproximately 2.5 minutes, which corresponds to the groove distances. After changing to a PID controller for the heated bed the temperature stayed within 0.1°C and the problem was gone. Several hundredths of a millimeter thermal expansion of the heated bed can have substantial impact at 0.1 mm layer height!

You can enable the PID controller for the heated bed in Marlin or Skynet firmware by enabling (removing the //) here:

//#define PIDTEMPBED

and disabling (putting // at the beginning of the line) here:


in Configuration.h. Calibration of the PID controller can then be done with the GCODE Command:

M303 E-1 S90 C8

for 90°C. I had to preheat the heated bed before, otherwise the calibration would run into a timeout. The command will return parameters for the PID algorithm. The values can then be applied by the

M304 P579.01 I100.87 D586.0

GCODE command (here for example values). Everything can then be saved to the EEPROM with


Bang-Bang controller: Bang-Bang controller

PID controller: PID controller

  • $\begingroup$ Welcome to 3dprinting.stackexchange.com, @uiop! This is an awesome, informative and well written answer, happy to have you onboard! :) $\endgroup$
    – mac
    Apr 7, 2018 at 0:07

Repeating patterns like that usually stem from issues in the Z axis. This is likely caused by bent screws which in turn cause the X axis to move around. Are the top of the threaded rods constrained? If they are, an easy fix may just be to let the top of the threaded rods float around by removing the constraint. Most Prusa i3's use 5mm threaded rod for the screws and 8mm smooth rod, does your printer use the same setup?

If your printer has 8mm (or 5/16") threaded rod you could try to get some that are straight or the better solution would be to get the 5mm threaded rods and just print adapters to hold the 5mm nut inside the trap. This would require new couplers (aluminum or rubber/plastic hose), 5mm threaded rods, nuts, adapters (printed) and a small change to the firmware. This works because the 5mm rod is more flexible than the 8mm smooth rod and less likely to force the carriage around.

If you already have the 5mm threaded rod/8mm smooth rod then I would look to make sure your X axis is tight and does not move around on the Z axis smooth rods.

This would be easier to point out if you include a picture of your printer.


If your printer is the mElephant from Makeblock then I would try removing the bearings at the top that constrain the threaded rods and try the print again.

  • $\begingroup$ Thank you for your detailed answer! I updated the question with images of my 3D printer. $\endgroup$
    – gpson
    Feb 9, 2017 at 14:40
  • $\begingroup$ It seems I edited my answer the same time you added the picture. I would try removing the bearings at the top that the threaded rods are held in if you can easily do that then try that print again. $\endgroup$
    – tjb1
    Feb 9, 2017 at 14:41
  • $\begingroup$ removed top bearings, problem persists $\endgroup$
    – gpson
    Feb 9, 2017 at 17:08
  • $\begingroup$ Do you see noticeable movement in the threaded rods? $\endgroup$
    – tjb1
    Feb 9, 2017 at 20:24
  • $\begingroup$ @gpson The bearings are part of the problem, not the complete solution of problem (but should be left out). Your steppers have integrated lead screws, any mis-positioning of these lead screws leads to x and y movement of the screw when advancing up or down. You need to separate this movement. One solution is using separate lead screws and springy couplers (but these introduce also problems). A better solution is to remove your lead screw nuts and print a sort of a lift platform that contains this nut, then you separated x and y movement from the lead screw completely. $\endgroup$
    – 0scar
    Apr 9, 2018 at 17:53

I have the same problem with a home made mini extruder. This happens only if the bearing stops rotating together with the extruder gear.

I notice that:

  • The gear collects burrs of PLA while feeding, so reducing the traction to feed the PLA
  • The bearing stops rotating when the pressure is too high or too low.
  • The heat of chamber is too high and starts to smooth the PLA before arrives to the nozzle and needs to regulate the speed of the fan. This creates less force on feeding.
  • The PLA has a mixture of ABS
  • PLA has part hardened due overcooking, extremely dry, etc.
  • The PLA have irregular diameters, for example is nominally 1.75mm but some sections vary 1.8mm or 1.9mm
  • The nozzle starts to get cold due direct fan air flow. (maybe your main problem)

:) I've been a Quality Engineer for 20 years for plastic and metal processes, so I've had to analyze why I've had lots of problems, especially in cold weather.

I was thinking on buying a new extruder like you have, but if you have the same problem I do, the Extruder is not the problem. You need to check the points I described above.

This is the extruder I have, http://aprendiendo.laconeccion.com/mini-extrusor-3dp.


Looks like something is catching on the z axis. A bent peice would likely cause much smaller deformations unless it was very obviously bent. Something could be loose, allowing the vertical play, perhaps the motor mounts.

More likely I think is a level-difference between the z-axis worm gears, possibly caused by an obstruction, lack of lubrication, or possibly even the wrong lubrication. That's where I would look. Further, since it's a very consistent pattern, my guess would be your issue can be isolated to the tops and bottoms of the z axis worm gears. Even if it's not the issues I think, the issue most likely located at the top or bottom.


I had a very similar problem once and the culprit was the relative position of the filament spool and the printer. The spool was standing on a coaster next to the printer and it turned out to be enough to create a pulling force on the filament. I have moved the spool to a shelf above the printer and the problem was gone.
However, your printer seems to have a way more rigid Z axis than mine, so it is unlikely the issue here.


Is your printer new?

It could be that the factory settings for the step number per millimeter or inch on the "Z" axis stepper motors. I personally have not had this problem however you might want to check out https://www.simplify3d.com/support/print-quality-troubleshooting/.

Hope this helps :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .