4
$\begingroup$

I've been recently building a 3D printer and I'm having issues testing it.

This is my hardware:

  • RAMPS 1.4
  • Arduino Mega 2560
  • 4x Pololu Motor shields A4988
  • 1x Nema 17 extruder
  • 2x floppy stepper motor
  • 1x DVD stepper motor
  • Generic hotend with 0,4 mm nozzle

Then I assembled everything and I started testing... I tried the RAMPS test code and it didn't work (motors did not move, but I'm sure they are OK), then I tried using Marlin and Pronterface; it showed hotend temperature stuck at 150°C, but the hotend was not hot. Moreover the motors would not move.

I also tried Repetier host and it returned an M999 error without any further explanation.

I had no problem installing firmware on the Arduino and the fan of the hotend is working. I also tried changing baud rate but it seemed not to work.

$\endgroup$
  • 2
    $\begingroup$ I don't think we can resolve this here; the troubleshooting required is too complicated and open-ended to fit in a stackexchange answer. Can you formulate a more specific question? Perhaps it is better to ask this on a site with a more "chatty" format. $\endgroup$ – Tom van der Zanden Mar 9 '17 at 20:12
  • 2
    $\begingroup$ Try disassembling your electronics, and testing the components individually: first the bare AtMega (can you upload firmware to it?), then add the empty ramps board (does it still work?), then install the thermistors and troubleshoot them, add the motor (drivers) one at a time, etc... By the way, what power supply are you using? $\endgroup$ – Tom van der Zanden Mar 9 '17 at 20:13
  • $\begingroup$ If you have had no problem in uploading the firmware to the Arduino (via the Arduino IDE?) and Pronterface connects to the Arduino Mega, then changing the baud rate will not help you at all, as it is clearly working well at its original setting. Changing it, may (as you have found out) stop it from communicating. It sounds as if some, or all, of the electronics is not wired up correctly (in particular the steppers and thermistor). Do as Tom says and connect it in steps and test each part as, and when, you connect it. What printer design are you building? Do you have any links? $\endgroup$ – Greenonline May 11 '17 at 6:49
  • $\begingroup$ What was the exact error that you received? Was it: Printer stopped due to errors. Fix the error and use M999 to restart? No additional information whatsoever? Please provide as much information as you can, in your original post. The more information that you provide, the more likely it is that someone will be able to provide yo with a solution. However, if you have managed to solve your problems, maybe you could post an answer, as it would probably help other people, who are experiencing similar or related issues. $\endgroup$ – Greenonline May 11 '17 at 7:04
2
$\begingroup$

Two immediate issues I can think of are:

  • Do the floppy drive and DVD drive stepper motors have sufficient torque to turn whatever you have connected them to? You don't say what sort of printer you have built, but a holding toque of 44 N·cm (62oz·in, 4.5kg·cm) or more, is desirable. Maybe you should consider upgrading your floppy ad DVD drive motors to Nema 17 motors... See RepRapWiki - Nema 17 for more details.
  • Do you have the correct thermistor selected in the firmware? Check your firmware configuration file.

To further check the thermistor, disconnect it from the RAMPS board, and using a multimeter, check its resistance at room temperature. Then compare it with the temperature characteristic graph of your thermistor type. A general 10K thermistor has the following response curve (source):

Thermistor response curve

Does the reading that your multimeter gives, seem reasonable?

Also check the RAMPS thermistor input, by shorting the thermistor pins on the RAMPS board (using a jumper). What is the temperature reading now? It should be whatever MAX_TEMP is defined as, typically around 400°C. Again, check your firmware configuration file.


In addition, M999 is not an error, but a command used to reset the firmware/printer, after an error has occurred.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.