2
$\begingroup$

My mono mendel 0,0 position is on the left of the bed, when the nozzle is at the position of the green dot in this image.

Mendel mono home position

I would like to move that point to the left a bit, in order to print a slightly larger part (the bed has about a centimeter more space to the left). I know I can just allow negative values but I'd rather not to, for safety reasons.

However I cannot find where the offset of that point from the endstops (home position) is declared. There is no offset set in either pronterface or Slic3r, and unless my board came preloaded with different firmware than the one reprappro publishes, the *_HOME_POS variables in their Marlin repository are all equal to 0.

// The position of the homing switches. Use MAX_LENGTH * -0.5 if the center should be 0, 0, 0
#define X_HOME_POS 0
#define Y_HOME_POS 0
#define Z_HOME_POS 0

https://github.com/reprappro/Marlin/blob/master/Marlin/Configuration.h#L290

Any ideas how I should go about it?

$\endgroup$
1
$\begingroup$

I think the cleanest option is to move the X-endstop back about a centimeter to match, and then increase the size of the bed in both Slic3r's and the printer's settings.

You could also try using M206 to set a persistent offset after homing.

$\endgroup$
  • $\begingroup$ I can't. The endstop is actually at the very beginning of the X axis (see picture above) $\endgroup$ – qwazix Apr 29 '17 at 13:22
  • $\begingroup$ M206 should still work, is it not supported by your firmware? $\endgroup$ – ctag Apr 29 '17 at 17:08
  • $\begingroup$ Haven't tried. I tried with G92 and it just did crazy things such as trying to honor both restrictions and thus restricting X movement completely. Will try and report back. $\endgroup$ – qwazix Apr 29 '17 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.