4
$\begingroup$

I´m currently working on a custom delta printer running Marlin 1.0.2 firmware. To control it I´m using the Repetier Host software with the onboard Cura software to slice my objects. The printing works fine but it takes the nozzle nearly 5 minutes to move from the homing position at 250 mm to the starting position of the print near z=0.

I already tried to increase the travel speed but nothing changed. Can you guys please tell me how to increase the speed of my nozzle to move down to my starting point of the print?

$\endgroup$
  • 3
    $\begingroup$ Please share the exact G-code that causes this problem. Without it we just have to take guesses at what is wrong in your settings. $\endgroup$ – Tom van der Zanden May 5 '17 at 12:48
  • 2
    $\begingroup$ As @TomvanderZanden says, the problem and the fix are most likely in your "start gcode" setting. You said "increase travel speed", but I think you meant you changed the travel speed setting in Cura, not in the specific line in the "start gcode" that actually does the travel from home to z=0. The start gcode will have something like G28 X Y Z F{some number} maybe twice, once fast and once slow. And then it may have a move to some start position (G1 X0 Y0 Z5 F{some number}) and it is that feedrate that matters here. (Perhaps you're using a snippet of start.gcode meant for a cartesion printer.) $\endgroup$ – Mark Walker May 5 '17 at 18:29
  • $\begingroup$ Is this during a G0, a G1, or a G28? Your max G0 speed may be set low; have you tried adding an F value on that homing move? $\endgroup$ – Davo May 8 '17 at 11:33
  • $\begingroup$ Without the G-code this is guessing, to follow up @MarkWalker, start G-code for CuraEngine from within Repetier-Host is found here. $\endgroup$ – 0scar Mar 12 at 11:59
5
$\begingroup$

I had the same problem, and I solved it by changing the Z-Axis Feed Rate to a much higher value (1000 mm/min.) in Repetier Host via Config -> Printer Settings -> Printer.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ I think the travel speed and z axis feed rate are different things though; the travel speed is used during the print to move the print head without printing while the z axis feed rate is used before the print starts. Either way, I've encountered the same problem as OP and my answer worked for me. $\endgroup$ – Zillo7 Feb 23 '18 at 17:44
  • $\begingroup$ my bad, I stand corrected, +1! :) $\endgroup$ – mac Feb 23 '18 at 17:54
-1
$\begingroup$
  1. I would guess (without G code) to change start G code. You should find it in Cura, the feed rate should be low there.
  2. Try other slicer and print from SD card.
  3. Try using other software. Try Cura it self if SD card printing is not available.

Picture is just an example what to look in Repertier or Cura. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Please answer this with the respective given stats in mind: OP already increased travel speed and uses Marlin 1.0.2 with control via Repetier Host (with Cura Engine). Your picture is not Repetier Host. $\endgroup$ – Trish Mar 12 at 6:40
  • $\begingroup$ The problem OP has is to do with Starting G-code, nothing to do with software. Offered to OP solution, change slicer and check if it's the same, look for starting G-code and change it because that's where the problem lies. $\endgroup$ – Martynas Mar 12 at 9:00
-2
$\begingroup$

Try changing the travel speed in you r slicer, if that doesn't work , try changing out the motors for newer ones.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ As stated in the question, they already tried that. Since after the initial travel move everything apparently works flawlessly, changing the motors seems pointless. $\endgroup$ – Tom van der Zanden May 7 '17 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.