I am having trouble printing a hollow object using Slic3r. On flat slopes on top, there are gaps that I cannot get fixed. The perimeters of successive layers just don't cover each other.

Cura however adds filament to cover the gaps.

The bottom left bunny is sliced with Slic3r The top right bunny is sliced with Cura 2.5. Take a closer look at the forehead and the back of the bottom left bunny.

I have "extra perimeters if needed" turned on. But turning it off makes no difference. What am I missing?

So far only adding infill and increase the solid top layer count helps to get a closed surface. But then everything gets stiffer. The bunnies are printed with nylon so they are a bit squishy.

Cura and Slic3r Bunnies

The printer settings in both Cura and Slic3r are:

  • 0.4 mm nozzel;
  • 0.2 mm layer height;
  • No infill;
  • 2 perimeter walls, and;
  • 3 solid top/bottom layers.
  • $\begingroup$ This is very similiar to the issue I had in 3dprinting.stackexchange.com/questions/3461/…. I think Slic3r simply can't handle this type of shape properly. In the end, I just use Cura. $\endgroup$
    – mbmcavoy
    Commented May 24, 2017 at 22:49
  • $\begingroup$ true, thats the same issue. I also already tried Slic3r 1.3 beta with the same result. Looks like Cura is the cure for that issue :) $\endgroup$
    – kwasmich
    Commented May 25, 2017 at 7:44

2 Answers 2


This seems to be a recurring problem with Slic3r.

Slic3r appears to have problems with perimeters that are not attached to infill. I suspect that it is getting confused on what is the inside and what is the outside. I know that seems a bit silly; but as you slice an object with indentations (like the bunny's face) then the perimeter can cease to be a simple closed shape and it gets confused. If you use a viewer to step through the gcode layers around the place it starts having problems you may be able to see what is going wrong.

Here are a couple of examples of why I say this is a recurring problem with slic3r. I also recall seeing a video that showed the problem but I can't remember where. That was one of the reasons I don't use slic3r.

Here are three options that may work

  1. Use a different slicer for this specific condition. Every product is going to have vulnerabilities - this may be one of slic3r's.
  2. Increase the perimeter and top and bottom layer thicknesses. Making them thick enough it will bridge the problem areas. Use a gcode viewer to inspect that area to see if it fixed the problem. That way you don't waste material on another fail. It sounds like you may have already tried this but you didn't like that it made the model stiffer.
  3. Repair the STL file using an application like Meshmixer. Maybe you will have to get the file close then tweak it where it doesn't. Here is good article from PinShape repairing and STL file.

Good luck, hope this helps.


What infill are you using? How flexible do you need the object to be?

I suggest two or three top and bottom layers, and a second or third solid perimeter as well.

The slicer has to determine if a particular path is part of an external perimeter or a top layer, so adding one to each should give a better result.

Thinner layers and a fan cooling the deposited material both help with overhangs like this.

  • $\begingroup$ I want the object to be completely hollow, so I used no infill at all in both, Cura and Slic3r. Cura adds more to the inner perimeter walls as they come closer to the problematic area. Slicer however does not. Since I practically used the same basic settings in both, there must be something I can tell Slic3r to do the same. $\endgroup$
    – kwasmich
    Commented May 24, 2017 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .