I have an E3D v6 1.75mm bowden.

When I print, there is a gap between infill lines, and also when printing rectilinear/hexagonal infill lines seem to be pretty slim.

My settings:

  • Slicer: Slic3r
  • Nozzle size: 0.4mm
  • Print speed: 30mm/s
  • First layer print speed: 15mm/s
  • Travel speed: 90mm/s
  • Retraction length: 0.8mm
  • Retraction speed: 40mm/s
  • Extrude ratio: 1 (tried also with 0.48mm extrusion width, I remember it's the default S3D setting, so I gave it a try)
  • Print temperature: 220 °C
  • Material: PLA

Firmware settings:

  • Firmware: Marlin 1.1.0-1
  • Motion system: CoreXY
  • Acceleration: 1000
  • VMax X: 300
  • VMax Y: 300
  • VMax Z: 5
  • VMax E: 80
  • Xsteps/mm: 80.05
  • Ysteps/mm: 80.05
  • Zsteps/mm: 400
  • Esteps/mm: 96.5

Disclaimer: I set Esteps/mm to 96.5 because I calibrated the printer as described here, so I'm 100% sure it's an accurate setting. Same for X,Y,Z steps. I printed a cube and calculated the real steps per millimeter, and it's accurate too. The extruder motor works, it's not the issue.

Here you can find some pictures that show what I'm trying to describe: enter image description hereenter image description here

While printing I tried to release the extruder motor clamp and push the filament by hand: it extruded 1mm thick lines, so the extruder is not clogged and is perfectly capable of extruding the required amount of PLA.

Is it possible that the VMax E parameter is preventing the extruder motor to extrude properly? I mean, could it be that it's trying to extrude at a higher speed than the maximum allowed? Seems weird to me, because comments in Marlin's Configuration.h file say Default Max Feed Rate (mm/s) for that parameter, so if the limit is set to 80mm/s it should extrude just fine. If this is the issue, how should I solve it?

  • This problem could be related to your slicer. Have you tried using a different slicer (Cura for example)? I have seen the gapping reported several times for slic3r that went away when they used a different slicer. – markshancock May 29 '17 at 5:57
  • @markshancock I use Slic3r since more than a year without issue, so I think it should work... I thought about a Marlin issue because this is a printer I assembled with components from another printer that had repetier. Same Slic3r settings which worked perfectly with the old Repetier firmware don't seem to work with Marlin, this is weird... Or maybe it's just that I had a direct extruder before and bowden requires some special settings...? – BackSlash May 29 '17 at 7:24
  • I am not saying that Slic3r is a bad slicer; but, every product has its vulnerabilities and I have seen several reports where people saw something like this and used a different slicer and they didn't see it; so, I didn't want to claim that as an answer; but, thought you should try it as an experiment to see if it resolves what you are seeing. – markshancock May 29 '17 at 18:16
  • Another trick I have hears to workaround this is to lie about your nozzle diameter. – markshancock May 29 '17 at 18:18
  • 1
    Maybe this would help manual.slic3r.org/advanced/flow-math – markshancock May 29 '17 at 18:23

Major factors affecting extrusion:

  1. Nozzle diameter
  2. Extrusion ratio
  3. Extrusion stepper calibration
  4. Filament actual diameter
  5. Extrusion width setting
  6. Nozzle temperature

According to the photos, temperature is acceptable (may be a bit high, but it is not a problem in this case). Extrusion ratio is 1 and should not be changed in normal operation. Extrusion width is often set to auto but sometimes calibrating it gives better results in slic3r. If stepper is calibrated properly, then I would check for nozzle and filament diameters. For nozzle it should be enough to verify that 0.4 bit fits in and 0.5 doesn't. Filament can be measured by digital caliper. Difference between 1.75 and 1.73mm may have significant difference resulting in under-extrusion.

  • Everything is calibrated. Extrusion width is set to 0.4, I also tried 0.48 (because Simplify3D does this by default, so I thought I could try that too), no luck. Stepper is calibrated, as wrote in the question. The filament actual diameter is quite accurate, as I said I never experienced this type of issue with the stock direct extruder and Repetier: all the troubles came when I switched to Marlin + E3D V6 – BackSlash May 29 '17 at 21:38
  • Do you use EEPROM in Marlin? Try to get current parameters via M503 command and check if they are the same as you expect – Mikhail Z May 29 '17 at 21:43

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.