5
$\begingroup$

I just installed a Ramps 1.4 board on to my Anet A8. Everything worked as it should except for the Z axis motors. The Ramps board I have contains two headers for each Z axis motor.

When both motors are connected, one of the motors squeals like something awful. When I disconnect one motor it turns smooth as butter. I have tried this for both motors and when only one is connected it works as it should but does not with both.

Has anyone experienced this? Is there a simple remedy for this issue? Any help is appreciated.

$\endgroup$
2
  • 1
    $\begingroup$ Did you orient the plug correctly? Flipping the plug of a correctly wired motor will reverse the direction on RAMPS. It may be that you had them fighting each other or the current isn't high enough on the driver. $\endgroup$
    – tjb1
    Jun 16, 2017 at 19:06
  • $\begingroup$ The plugs are oriented properly. The threaded rods are also removed so the motors shouldn't be interacting with each other. I even swapped out the driver board with another and I still get the grinding sound from the servos when they are both connected. Does the potentiometer on the driver raise/lower the current? $\endgroup$
    – Krizzle
    Jun 16, 2017 at 19:37

1 Answer 1

2
$\begingroup$

Found the issue. The steps were set way to high. I lowered my steps to 500 and the steppers seem to perform as they should.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .