3
$\begingroup$

So I have been going through modding my printer and I have come across a new problem that I have not had issues with before.

My 3D printer will start to print above the heating bed even though it gets properly homed all the endstops. At first it was off by half of the whole Z-axis distance using Cura and off by 0.5 mm on MatterControl. Since playing around with random settings in both programs, my printer now seems to only be off by 0.25 mm from the heating bed. None of the settings appear to be affecting anything.

My guess is something both programs remembered was off and now it's been corrected to a degree?

Homed at endstops:

Homed at endstop

Homed to a papers width above the heating bed:

Homed to a papers width

Here the printer has started to print and it off by 0.25 mm:

Started to print

G-code

MatterControl: enter image description here

Cura:

M190 S75.000000
M109 S230.000000
;Sliced at: Mon 10-07-2017 01:08:42
;Basic settings: Layer height: 0.1 Walls: 0.4 Fill: 2
;Print time: 2 hours 18 minutes
;Filament used: 3.348m 9.0g
;Filament cost: None
;M190 S75 ;Uncomment to add your own bed temperature line
;M109 S230 ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
;G1 Z15.0 F6000 ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G92 E0                  ;zero the extruded length again
G1 F6000
;Put printing message on LCD screen
M117 Printing...

;Layer count: 381
;LAYER:0
M107
G0 F6000 X96.660 Y119.366 Z0.100
G0 X96.978 Y119.129
;TYPE:SKIRT
G1 F1200 X97.452 Y118.764 E0.00995
G1 X97.921 Y118.508 E0.01883
G1 X98.363 Y118.264 E0.02723
G1 X98.699 Y118.142 E0.03318
G1 X98.699 Y118.143 E0.03319

Further down.

;LAYER:1
M106 S63
G0 X111.565 Y151.164 Z0.200
;TYPE:WALL-OUTER
G1 F1920 X111.415 Y151.002 E40.19917
G1 X110.919 Y150.231 E40.21441
G1 X110.689 Y149.702 E40.22401
G1 X110.553 Y149.385 E40.22974
G1 X110.226 Y148.153 E40.25094
G1 X109.962 Y146.354 E40.28118
G1 X109.635 Y143.890 E40.32251
G1 X109.603 Y143.683 E40.32600
G1 X108.787 Y143.726 E40.33959
G1 X108.787 Y143.930 E40.34298
G1 X108.518 Y146.454 E40.38519
G1 X108.184 Y148.175 E40.41434
G1 X107.746 Y149.645 E40.43985
$\endgroup$
7
  • 1
    $\begingroup$ Consider adding the start G-code to your post (plus the first few commands of the print itself), so we can see what you're actually instructing the printer to do when it starts a print. $\endgroup$ – Tom van der Zanden Jul 6 '17 at 10:30
  • $\begingroup$ Alright, I have added the g code. I know im not the only one with this problem but im not sure if anyone has found a solution. $\endgroup$ – Chris Manning Jul 6 '17 at 16:09
  • $\begingroup$ We need to see the beginning of the print code, what you have added is basically just the startup code and doesn't actually show the positioning of Z other than Cura homing and then going to Z15 and MatterControl just homing. $\endgroup$ – tjb1 Jul 6 '17 at 16:40
  • $\begingroup$ I can't see the screen on the printer. What z does it show when it is printing the first layer? $\endgroup$ – markshancock Jul 6 '17 at 20:35
  • 1
    $\begingroup$ I have put this question on hold until further information is given. $\endgroup$ – Tormod Haugene Aug 3 '17 at 7:13
1
$\begingroup$

Try setting your "First Layer Height" to 0. This should resolve the issue and will make homing your Z axis a bit easier.

$\endgroup$
1
  • $\begingroup$ How does this solve the issue? Wouldn't that normally crash the hotend straight down into the build plate? $\endgroup$ – Tormod Haugene Jul 24 '17 at 8:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.