3
$\begingroup$

Cura is slicing my object (a gear with text) with a partial top layer, and I believe it has to do with layer height and rounding issues. I have been able to solve this at specific heights 10-14mm using a layer height of 0.25 mm, however other heights will cause this issue to arise again. There must be a solution to this that doesn't require the user to constantly be adjusting layer height and object height in order to resolve what I perceive to be a rounding issue.

Here is the model: https://filebin.ca/3f2g2s0dklzR/hackEly_v1.0_joined_text_2.stl

Here are my settings: Settings 1 Settings 2

Here is the model at a height of 10 mm: Note the diagonal line, this is the line between two layers. Object 10mm

Here is the model at a height of 13 mm: Note the diagonal line again, and how it is farther to the right than the 10mm height view. enter image description here

I don't believe that this is not a non-manifold issue. I have also tested this using a gear without text.

Like I mentioned, I can get rid of that layer division at certain layer heights and object heights (e.g. 0.25mm layer height), but I would like to find out how to get rid of this issue regardless of object/layer height. Thank you for your help.

$\endgroup$
2
$\begingroup$

Your model isn't perfect. I took it into Windows 10 3D Builder for simplicity. I kept clicking the "Mirror" function and noticed as it basically flipped there is some slight movement. I measured some points from bottom to top and noticed some differences.

Try to take your model into some software to fix/flatten it. Or recreate it making sure its perfectly flat on both sides. It is definitely not your Cura software.

$\endgroup$
  • $\begingroup$ Wonderful. I did not anticipate that the Z axes on the horizontal sets of vertices would have become uneven. Thank you so much for pointing this out. $\endgroup$ – Frumples Oct 25 '17 at 22:23
1
$\begingroup$

Even though you've selected an answer, here's another viewpoint. Ignoring the brim that I've added by default via my slicer, you can see the first few layers are not complete. This indicates a model that's a fraction of a degree off-plane.

slanted model image

Any number of methods can be used to correct this. Meshmixer has a great "align" function in the edit menu which will drop it on the bed. My slicer, S3D will work in that respect with "Place surface on bed" or some such terms.

The image below represents the result of using Align in Meshmixer, Inspector (repair all) and export. The STL file imported to S3D presented exactly the same image on the first layer as in the image above. When I used "Place surface on bed and selected the horizontal cross-member as the reference surface, the first layer result is this:

first layer after repair

The slicer completed the imaging with this result, clearly with no diagonal artifacts:

last layer

$\endgroup$
  • $\begingroup$ This still wouldn't correct the object not being perfectly shaped. The best it would do is orient the object to have the most surface area touching the bed. But that slight rotation wouldn't make the last top layer perfectly horizontal for that finishing layer. $\endgroup$ – Athanasios Karagiannis Oct 26 '17 at 16:35
  • $\begingroup$ As I've often seen in models available on the 'net, the model contains parallel faces, but is positioned in error. This appears to be the case in the OP's model. My recent edit to the post shows that when the base of the model is flat to the build plane, the top aligns itself. $\endgroup$ – fred_dot_u Oct 26 '17 at 17:20
  • $\begingroup$ I brought the model into RH and performed the layflat option. It applied 0.073027 rotation on X, 0.122294 rotation on Y, and -43.986123 rotation on Z. I sliced it at 0.2mm and 0.3mm and the first layer looks clean flat. The last layer before the letters was clean flat as well, but in both layer height slices the lettering was one layer off. I really don't think the OP would mind half of the lettering to be one layer higher since it won't be noticeable. While this does fix his initial issue, providing a flat cog finishing layer, the measurements of the model are still off. $\endgroup$ – Athanasios Karagiannis Oct 26 '17 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.