5
$\begingroup$

Recently, I changed my RAMPS 1.4 card (because there was a problem with the power output).So I bought this new one, and an Arduino Mega.I didn'T change the code (Marlin 1.3.3).I used the same stepsticks (a4988).I plugged my motors to the Ramps card. When I give them the command to turn they started to turn but didn't stop.Stepsticks got hot.After some time I tried it again and they just vibrated.The stepsticks got insanely hot after just 5-6 seconds.I used a different stepstick RAMPS card and Mega, they worked perfectly.But when I plugged the stepstick to the new card, the motors did te same thing again. What can be causing this and how can I fix it? (I've measured the voltage input, it is 12V and stable)

$\endgroup$
3
$\begingroup$

Usually if they get too hot you have to adjust the amperage by turning the little potentiometer on the A4988 (turn left until you can move the motor by hand, turn right until you cant, add a little bit like 1/8 to 1/4 of a turn).

But this:

I used a different stepstick RAMPS card and Mega, they worked perfectly.

it is not completely clear, so:

  • the A4988 work on another board -> your new board is broken

  • another A4988 worked -> the A4988 is broken

HTH

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.