I have made a custom 3D printer with RAMPS electronics. I have printed a Benchy (ship) well, but when I try to print anything with teeth (spiral vase), gears (bearing), or a circle (rocket), the Y-axis skip steps in a regular rate giving 70-60 degrees skew along the printing the Y-direction, but each layer is perfect, this happen when printing gear bearing.

  • I have checked Y-axis ball bearing, motor, tension belt and I have replaced my 6 mm glass with 1 mm without any difference in shift.

  • I have once make it work, but I don't why or how (I have lowered speed to 50 and did some random things).

  • I have printed from Pronterface and when I pause it, then home Y, the skipping in Y is corrected.

  • If I drive my X/Y-axis with no microstepping, then the skipping is much larger.

  • I only use Slic3r for G-code generation.

with no micro stepping

with 32 micro stepping

with 32 micro stepping with 32 micro stepping with 32 micro stepping question:

  • What is the cause for that skipping?

  • If there is more than one possibility, how could I check them separately?

  • I have changed my Y-axis motor with no change.

  • I have swapped X&Y connections with no change - still Y skips.

  • I have lowered jerk and max. speed and it prints gear bearing well and it is spinning, but when I tried to print spiral vase Y motor skipped.

  • $\begingroup$ MIght be loose belts, leading to position hysteresis. Check the tension. $\endgroup$ Nov 6, 2017 at 15:05
  • 2
    $\begingroup$ Out of curiosity, what's the white horror on your build plate? $\endgroup$
    – Valmond
    Nov 8, 2017 at 10:04
  • $\begingroup$ accumulated glue stick $\endgroup$
    – I.Omar
    Nov 8, 2017 at 21:52

2 Answers 2


I would assume it is either the stepper driver or the stepper motor. Try switching the motor wires for x and y axis and see if the problem stays with the motor or the driver. If its not physically getting hung up then this is likely. I had the same problem with my y axis and after switching the motor it was gone. It would only skip steps in one direction and that seems to be exactly whats going on. Most likely it was caused by bad windings on 1 of the 2 coils inside the stepper motor.

  • $\begingroup$ I have changed stepper motor with the result, so I think the problem with the inertia of my Y axis. $\endgroup$
    – I.Omar
    Nov 8, 2017 at 22:06

Maybe your motor skips?

I had my Z motor skip sometimes, this was the reason:

1) Acceleration was too high

2) I needed to tune the "amperage" (the current) of the pololu driver

3) Speed was too high

So, you can try to lower acceleration, speed and tune your driver:

Power on everything, see if you can turn the motor by hand (you shouldn't). Turn the small potentiometer on the driver board counter clockwise until you can turn the motor, turn it back until you can't turn the motor any more and then add some 1/8 - 1/4 turn.

You might also want to check your 'jerk' settings so they are not too high either.

  • $\begingroup$ I set it to max where the motor doesn't heat up, should I go more than that? $\endgroup$
    – I.Omar
    Nov 8, 2017 at 22:03
  • $\begingroup$ Just lowering the current so the motor doesn't heat up might be not enough current. Classic NEMA motors can get quite hot (but of course, don't overdo it) without short term implications, so I'll say try some more juice and see if it fixes the problem! If it doesn't, lower the current to your old level. $\endgroup$
    – Valmond
    Nov 10, 2017 at 8:48
  • $\begingroup$ I have did that but still Y axis skips when printing spiral vase, so I think I should change the mechanics of my Y-axis or try nema 23. I am getting my mid-term exams atm. $\endgroup$
    – I.Omar
    Nov 10, 2017 at 11:44
  • $\begingroup$ I have had a Pololy driver fry, the ATMega board fry and both times, they actually worked, almost, okay. Try to switch pololu drivers (betxeen say X and Y), try to exchange the cable positions for X and Y motor, and eventually, try another Arduino. $\endgroup$
    – Valmond
    Nov 10, 2017 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .