1
$\begingroup$

I've saved settings in the slicer for pla and abs, set the default bed temp to 90 and extruder to 185. No matter what settings I select to print with, the bed temp sets to 110 and the extruder to 230 when I send a job to print which I don't want. If I then control the heat manually, repetier or the printer seems to ignore my requests. If I try to kill the job I keep getting a box coming up asking me to switch the heats off; I select yes and nothing happens.

If I use the emergency stop the heats switch off.

$\endgroup$
4
  • 1
    $\begingroup$ Can you please include the slicer that you are using, and also the g-code start sequenced (that gets prepended to each print job)? $\endgroup$
    – Mick
    Nov 23 '17 at 10:56
  • $\begingroup$ @james all slicers control your temperatures, set and verify your parameters on each gcode to validate everything is right. Try to send a print that you want not the ones that you don't want to avoid motor and heating stops. $\endgroup$ Nov 26 '17 at 8:24
  • $\begingroup$ also, there are paramters that slicer includes to "optimize the prints" but these lines need to be changed or removed from extra settings. $\endgroup$ Nov 26 '17 at 8:27
  • $\begingroup$ What slicer are you using? $\endgroup$
    – Davo
    Nov 27 '17 at 12:31
1
$\begingroup$
  1. You may set the temp in Repetier but when you run the gcode it will send any of the temp settings in the file. So you may set 210 °C first but if 200 °C is in the G-code the printer will take that (as the gcode is sent one instruction at a time). However I also noticed that after the automatic bed leveling any manual settings on the printer are reset to the G-code (I assume the file is re-stating the temp after bed leveling) So I have to override the file temp after the bed leveling is complete.
  2. I now use OctoPrint and it has a cool feature : temp offsetting, you can specify an offset for every temperature the OctoPrint server sends to printer; e.g. in your file it is set to bed: 110 °C and extruder: 230 °C you can tell OctoPrint to take 20 °C off all bed temps sent and 45 °C off any extruder tempperatures sent. It's great for tweaking the temperatures of your G-code without editing or re slicing, just change the temperature offset and reprint.
  3. I noticed on a previous firmware version for the I3 mk2s Repetier did not connect properly to the printer this problem disappeared in the latest Prusa firmware (v3.1). One of the symptoms I noticed was the temperature settings were not taken by the printer.
  4. Some slicers have a setting to have sticky parameters, i.e. set temperature once don't bother re-sending. However if this was turned off, it is possible that the generated G-code repeatedly send the temperature settings with every instruction, continuously resetting and overriding these values. (OctoPrint temperature offsets would correct this)
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.