6
$\begingroup$

I accidentally let the print head of my Anet A8 crash into one of 2 clips that are holding a glass sheet onto the hot bed, and suddenly the screen went blank and the printer rebooted, then it started reading 739°C from the extruder thermistor. I tried changing the thermistor, but that didn't have any effect. Also tried swapping the extruder thermistor with the hot bed thermistor, but there was no effect on both. I checked both the connector and the socket of the thermistor for shorts but found none. Any ideas about the reason this is happening?

-Using Skynet3D 2.3.2 on the stock Anet board.

EDIT

I tried burning the bootloader and flashing the firmware onto the Anet V1.0 board using an Arduino UNO as an ISP, but that had absolutely no effect.

EDIT 2

I measured R41 located next to the hotend thermistor header R41 location and found out it has a resistance of 1.5kΩ, while it should have a resistance of 4.7kΩ, so I suspect this is the main reason behind this high reading. Now the only thing left to figure out is how the resistance of this resistor changed.

I was able to figure out which resistor to measure with the help of this schematic: https://github.com/ralf-e/ANET-3D-Board-V1.0/blob/master/ANET3D_Board_Schematic.png

EDIT 3 I tested T56 (located near the headers) and T55 (located near the ATMEGA1284P) for continuity, and found out there's no connection between those, while they should be connected according to the schematics. I also checked the hotbed's terminals T54 and T53 and found continuity between them, which means the problem might be in the trace between the thermistor header and input pin of the ATMEGA chip (this trace is VERY thin, so any overcurrent might cut it), or any component in this trace.

$\endgroup$
  • $\begingroup$ My guess is the A/D converter chip, or a trim resistor attached to it, is blown, so the reading is pinned at some absurd binary value. $\endgroup$ – Carl Witthoft Dec 12 '17 at 13:47
  • 1
    $\begingroup$ Did the flash ("burning") succeed? Or was the flashing itself a no-success? $\endgroup$ – Valmond Dec 19 '17 at 13:38
  • $\begingroup$ @Valmond yes it succeeded with the arduino as ISP method, but flashing with a USB cable doesn't work, and it just keeps giving me out of sync errors. $\endgroup$ – Tooniis Dec 20 '17 at 12:57
  • $\begingroup$ smells like a fried board, as you can't flash with USB and it just happened "like that". I don't know your printer so please tell if a crash on a clip could break the electronics / some cable (it seems unlikely butt maybe your printer is made so it might happen)? $\endgroup$ – Valmond Dec 20 '17 at 13:37
  • $\begingroup$ Having read the issue, it seems that this is a common problem for the ANET3D board. I'd like to ask two questions: 1. Is it possible to sever connections to the ATMEGA and use the hardware itself while controlled with the Raspberry Pi or some other dev board? 2. While waiting for a new board (seems to be the only cost/time effective choice), is there any way to use the other temperature circuit (likely having to do some work in Arduino IDE)? My Hot End decided to set itself to 265°C while my bed is reading the new thermistor on the new Hot End just fine. I need to get a few prints made while w $\endgroup$ – user11040 Jun 10 '18 at 15:35
4
$\begingroup$

I had the same issue. Hot-end temperature reading stuck at 209 degrees even with hot-end thermistor disconnected or swapped with bed thermistor on the Anet A8 mainboard.

After ordering and swapping the AtMega1284p (using jtagice3 and hot-air soldering station) and the 4.7 Kohm resistor (which measured 2.06Kohm on the board and 4.7kohm off the board) to no avail, the only component left in the circuit that could cause the failure was the capacitor.

Swapping the capacitor C47 fixed the stuck reading for me. I used a 10uF instead of a 15uF capacitor as indicated in the schematic. I do not believe it makes much of a difference, and they are much more common. Make sure the capacitor can withstand at least 10V, but I got a 30V one, because the price was similar.

To any body that runs into this issue, before spending time and money swapping components like I did, measure the voltage of the node between R41 and C47 with respect to ground. This is labeled T56 or test point 56. Compare this voltage to T54, T60, T58, and T62 where similar circuits are placed. You should get a voltage of around 5V ( the pull-up voltage) in the functioning circuits, since we are talking about DC voltage, the capacitor should charge up nearly instantly when the the board is powered, and behave as an open-circuit.

In my case, C47 was almost in full short-circuit, and I read a low voltage on T56 ( ~0.5v).

Since the capacitor was in a low impedance failure mode, the 5V supply voltage of the voltage divider circuit was not enough to power it, hence the fixed temperature readings of the hot-end thermistor ADC channel regardless of the thermistor being connected or not.

Good luck!

$\endgroup$
3
$\begingroup$

and found out it has a resistance of 1.5kΩ, while it should have a resistance of 4.7kΩ, so I suspect this is the main reason behind this high reading. Now the only thing left to figure out is how the resistance of this resistor changed.

You can't measure the resistance of a resistor in circuit - the resistance probably appears to be lower to your multimeter because of some other circuit elements. There's also no reasonable explanation for how a 4.7k resistor could suddenly turn into a 1.5k one. It's highly unlikely this resistor is the cause of your issues.

It is more likely something else is damaged, likely the AtMega1284p microcontroller itself. When your extruder touched the bed clip, perhaps the 12V from the bed shorted through the clip and to the extruder? I would guess that the 12V shorted itself to the thermistor input, which subsequently blew the ESD protection diode on that input. This might explain the high reading and the low apparent resistance of R41.

$\endgroup$
  • $\begingroup$ The reason why I am assuming my measurement is accurate is because when measuring the resistor next to it R37 which is part of a similar circuit, it measures 4.7kΩ. $\endgroup$ – Tooniis Feb 6 '18 at 11:33
  • $\begingroup$ The 5V regulator is fine since the other sensors which are getting power from it work perfectly. It could be the diode you mentioned, or the input pin which the thermistor is connected to in the ATMEGA1284P chip. $\endgroup$ – Tooniis Feb 6 '18 at 11:36
  • 1
    $\begingroup$ @Tooniis As I mentioned in my answer, applying 12V to the thermistor input would damage the ESD diode on that input. The ESD diode connects the pin to 5V, so that in case of an overvoltage current can flow to the 5V pin. If the ESD diode is indeed damaged then it could be in a permanently conducting state, lowering the resistance. $\endgroup$ – Tom van der Zanden Feb 6 '18 at 12:38
  • 1
    $\begingroup$ Is "the ESD diode on that input" something that can be replaced or is it internal on the chip? $\endgroup$ – Paul Whiteley Jun 4 '18 at 19:24
  • 1
    $\begingroup$ @PaulWhiteley It is internal. $\endgroup$ – Tom van der Zanden Jun 10 '18 at 16:00

protected by Community Aug 31 '18 at 7:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.