5
$\begingroup$

I recently upgraded my Geeetech Acrylic Prusa i3 with a MKS Base V1.4 and it would not recognize the thermistors (100K {type 1}) even though they worked fine with the Arduino Mega 2560 with the RAMPS shield.

After changing the thermistors for the 4th time it began to work, but the model printed was quite distorted. Then without warning it suddenly does not recognize them again. The board does create the USB port, but does not appear to communicate with my computer.

Is the problem more associative with the board or my computer?

$\endgroup$
  • $\begingroup$ Does the one that stopped getting recognized, still get recognized by the arduino? $\endgroup$ – Eric Johnson Feb 8 '16 at 23:15
  • $\begingroup$ What exactly means "{type 1}". And did you alter your firmware? $\endgroup$ – amra Feb 10 '16 at 8:22
  • $\begingroup$ @EricJohnson It was both thermistors that stopped being recognized. If there is another way of determining whether the Arduino recognizes them other than through the computer (Repetier Host) I am unaware of it. $\endgroup$ – BYE Feb 10 '16 at 12:08
  • $\begingroup$ @amra Arduino configuration.h lists thermistors/thermocouple by type, and there are a large number listed there, my particular thermistor is a 100K type 1 on that list. $\endgroup$ – BYE Feb 10 '16 at 12:12
  • $\begingroup$ I see. My assumption was that you have wrong configuration in your firmware. Did you try another SW instead of Repetier Host, e.g. Pronterface? $\endgroup$ – amra Feb 10 '16 at 13:28
2
$\begingroup$

You should:

  1. Ensure that firmware has proper thermistor configuration. For details see this video tutorial.
  2. Verify that your thermistor works properly. Measure voltage on it. It should be around 5V on this particular board.
  3. There is possibility that the board is defective. Replace it.

Temperature sensor possibilities for Marlin firmware:

// -2 is thermocouple with MAX6675 (only for sensor 0)
// -1 is thermocouple with AD595
// 0 is not used
// 1 is 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
// 2 is 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)
// 3 is Mendel-parts thermistor (4.7k pullup)
// 4 is 10k thermistor !! do not use it for a hotend. It gives bad resolution at high temp. !!
// 5 is 100K thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (4.7k pullup)
// 6 is 100k EPCOS - Not as accurate as table 1 (created using a fluke thermocouple) (4.7k pullup)
// 7 is 100k Honeywell thermistor 135-104LAG-J01 (4.7k pullup)
// 71 is 100k Honeywell thermistor 135-104LAF-J01 (4.7k pullup)
// 8 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup)
// 9 is 100k GE Sensing AL03006-58.2K-97-G1 (4.7k pullup)
// 10 is 100k RS thermistor 198-961 (4.7k pullup)
// 11 is 100k beta 3950 1% thermistor (4.7k pullup)
// 12 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup) (calibrated for Makibox hot bed)
// 13 is 100k Hisens 3950  1% up to 300°C for hotend "Simple ONE " & "Hotend "All In ONE"
// 20 is the PT100 circuit found in the Ultimainboard V2.x
// 60 is 100k Maker's Tool Works Kapton Bed Thermistor beta=3950
//
//    1k ohm pullup tables - This is not normal, you would have to have changed out your 4.7k for 1k
//                          (but gives greater accuracy and more stable PID)
// 51 is 100k thermistor - EPCOS (1k pullup)
// 52 is 200k thermistor - ATC Semitec 204GT-2 (1k pullup)
// 55 is 100k thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (1k pullup)
//
// 1047 is Pt1000 with 4k7 pullup
// 1010 is Pt1000 with 1k pullup (non standard)
// 147 is Pt100 with 4k7 pullup
// 110 is Pt100 with 1k pullup (non standard)
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.