8
$\begingroup$

I am using Cura to slice my prints, and despite turning the flow rate to the minimum value of 5%, my prints are still hugely over-extruding.

I have calibrated the extruder stepper perfectly, using Pronterface, so I do not understand why this is occurring. I have also timed how long it took to extrude a certain length and compared it to the length of time it was meant to extrude and it was exactly the same. Therefore, I have concluded it is not a problem with the calibration of the stepper.

So, I think there is a problem with the settings on Cura. Originally, I had the flow rate at 100% and this was really, really terrible. Then I turned it down as far as possible and the print got better but there was still over-extrusion. I can't down it down any further.

I can not figure out what the problem could possibly be and as you would imagine it is very, very frustrating.

Here is the print profile:

Screenshot of Print Profile

So the printer is not of any model, as it is a homemade CD drive 3D printer. It shares many similarities with the Curiosity3D printer, so if you want more information on how it works, then their website will be of much value.

The extruder is a Bowden-style one. It uses a cheap E3D hotend and a RepRap extruder kit as the motor.

Here are the Machine settings:

Screenshot of Machine settings

This is a photo of two failed prints. On the left is a G and on the right is a heart.

Photo of two failed prints

This is what it was the G was meant to look like:

Pronterface G

So here is my configuration.h file which I previously modified for my 3D printer. The filament I use is "Robox PLA SmartReel Cornflower Blue".

$\endgroup$
9
  • $\begingroup$ 210 is a bit much for pla, i suggest going for 185 or 195. Do you have a picture of the result you get? You say its under extruding but with a picture we can determine better if it is or not. $\endgroup$
    – Granny
    Commented Dec 19, 2017 at 8:04
  • $\begingroup$ Maybe you do not have microstepping enabled (so extruding, for example 16 or 32 times too fast) $\endgroup$
    – Valmond
    Commented Dec 19, 2017 at 10:43
  • $\begingroup$ @Valmond I currently have all three jumpers slotted onto the pins on the extruder stepper driver area of the ramps board. I thinks this give 64x microstepping. Is there a setting I have too change, if I do this? $\endgroup$ Commented Dec 19, 2017 at 11:06
  • 1
    $\begingroup$ No, if it would have been the other way around then maybe, but for this you seem to be good. Now with your added printer info, what firmware do you use? If it is Marlin (as the Curiosity3D does), then check the extruder configuration! You have direct drive (as Curiosity3D ), many use geared down drive which could be your problem. Have you flashed it yourself? $\endgroup$
    – Valmond
    Commented Dec 19, 2017 at 11:13
  • $\begingroup$ 1) Plz post Configuration.h from Marlin firmware 2) Is the EEProm activated? $\endgroup$
    – Valmond
    Commented Dec 19, 2017 at 13:35

5 Answers 5

4
$\begingroup$

First of all: Can you tell us, what kind of printer do you use and which material? Please give us some pictures of some prints as well.. Also the type of the Extruder setup is relevant. Is it a Bowden or Direct Driven extruder?

For an FDM machine like the Prusa styled printers with PLA:

  • Flow of 5 % is totally wrong, normally PLA should be run between 90 % and 105 % flawlessly. The problem is elsewhere but not with the Flow settings, nor the Temp is the faulty one.
    • Temp between 185 °C and 210 °C should be fine for most PLAs
    • Did you set up your printer correct in Cura (Preferences -> Printers -> Machine Settings)? Material Diameter, Nozzle size and G-Code flavour are correct?

If you give us some more information, I will be glad to get this solved.

$\endgroup$
1
  • $\begingroup$ As i can see from your images and your additional info, you suffer from multiple issues. It looks like your printing way too fast (reduce acceleration and jerk for all motors). As other guys mentioned: check that your motors don't skip steps. Maybe your Z-height is not well calibrated too. $\endgroup$ Commented Dec 20, 2017 at 10:38
3
$\begingroup$

The fact that your printer is a scratch build using low-power stepper motors would tend to indicate that the problems lie in your hardware and/or firmware. It is very difficult to provide advice for such printers, simply because most 3D printer owners will have zero experience with them.

Possible candidates for the causes of your problem are fairly obvious:

  • Check that the stepper motors are not skipping, and that you have the correct number of steps per millimetre.
  • Check that your extruder is not skipping, and has the correct number of steps per millimetre.
  • Check that your firmware is matching filament flow with extruder speeds correctly.
  • Check that your firmware is configured correctly. How you do this for a scratch build is largely down to you.

One thing that I would advise is that you reduce the jerk and acceleration values, since they look to be far too high.

You have done well to get so far with such a build, but you may have to ask yourself if there is anything to be gained in continuing with your project.

$\endgroup$
1
  • $\begingroup$ Look at the image posted, the motors are obviously skipping. His problem is not skipping though (in this post), but the extruder motor extruding too fast. $\endgroup$
    – Valmond
    Commented Dec 19, 2017 at 13:33
3
$\begingroup$

I guess that either you have the hotend too far away from the first layer (so looks like underextrusion), then wrong layer height / wrong z-configuration so the layers are too small, making plastic pile up (seems like over extrusion). Eventually if the Z-Driver skips steps, it could look the same (printer trying to print the same layer several times).

There is also some skipping in the drivers, as your layers are not correctly on top of each other, check if you can 'up' the amperage in the drivers, or slow everything down (speed, acceleration & jerk) til it works without skipping.

My best bet is that you should 1) first make your drivers stop skipping, 2) then carefully calibrate your machine using the configuration.h (line 527) so that x,y,z,e are all roughly okay at least.

Then start printing :-)

On a side note, you can also activate the EEPROM and store the new values with GCode, this is mostly a 'convenient' thing because you don't need to recompile and flash your board at every change, so maybe do that later when everything starts to work out OK.

HTH

$\endgroup$
1
$\begingroup$

I fixed this issue a while back but I realised others might see this. I’m not exactly sure what fixed it though. I was meddling with the ee-prom when suddenly it started working again. I suspect somehow a different steps per mm value was stored on the ee-prom so no matter what I did to change it (in the firmware) it made no difference. Then I either changed the settings in the ee-prom or disable it. I can’t really remember.

When it started working it looked like nothing was extruding because 5% extrude rate really is very low!

$\endgroup$
1
$\begingroup$

I've been building 3D printers for a few years and working in the computer science field for over 2 decades. Here's a simple trick I use for adjusting your extruder steps.

  1. Tweak your flow rate till it's where it should be. Then mark down the percentage it's at.

  2. Go into your configuration file and use that percentage to adjust the number of steps. So if $x$ is the number of steps and our flowrate is at 40 % to be extruding normal then:

    $x * 0.4 =$ new step count

  3. Save the file and compile.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .