4
$\begingroup$

After a long time tweaking my new 3D printer I solved all the unexpected errors and I can print succesful pieces but I am facing a "problem", they are over sized, I found this problem trying to print a Raspberry Pi Case and an smartphone case, the printed pieces are bigger than the objects.

Here some related information

Printer: Geeetech Prusa i3 Pro B

Firmware: My GitHub (Marlin)

Software: Repetier Host with Slic3r

Does somebody know how could I solve it? Thank you very much

$\endgroup$
7
  • $\begingroup$ Is this with every print? Or did you hit the scale multiplier by accident? And have you changed/modded your printer? $\endgroup$
    – Granny
    Jan 9 '18 at 14:47
  • $\begingroup$ I could sure it is with every print, I tried to print yesterday another fixed size piece (the third one, in different dates) and it is bigger than it should be. I am suspecting about the step per mm option in the firmware. let me mention they aren't too much bigger, just some mm, but enough to don't fit the objects $\endgroup$ Jan 9 '18 at 14:50
  • $\begingroup$ If you have changed any poulies or belts your steps per mm could have changed and with this your printer will go further or shorter than its actually supposed to be. $\endgroup$
    – Granny
    Jan 9 '18 at 14:52
  • $\begingroup$ I didn't changed them, the oversizing problem is probably there from the beginning but I didn't noticed it until now, when I tried to print fixed size models. This evening I will try to check the step per mm configuration and let you know. Thanks @Granny $\endgroup$ Jan 9 '18 at 14:54
  • 2
    $\begingroup$ I finally solved it by reducing the steps per mm in the printer firmware. Thank you all $\endgroup$ Jan 10 '18 at 7:53
3
$\begingroup$

You have to know:

  • distance between belt teeth (usually 2mm)
  • number of teeth on pulley
  • motor step angle 1.8 deg?
  • microstepping count, probably 16?

Then you can enter all these numbers info the calculator here: https://www.prusaprinters.org/calculator/

$\endgroup$
5
  • $\begingroup$ This helps but I had to do some manual adjustment in the step per mm option to solve it. Thank you very much $\endgroup$ Jan 10 '18 at 7:52
  • 1
    $\begingroup$ Yes, the result of the calculation should be entered as the steps per unit, and if the information is correct this should be a first-time accurate solution. Experimenting as described in Alberto's answer will work if you don't know the mechanical parameters, but may not be very accurate and will take multiple iterations to get "close enough". $\endgroup$
    – mbmcavoy
    Jan 11 '18 at 20:07
  • $\begingroup$ I will try it again because as you say my method can lead to errors, when I have done it I will update all the information. The changes didn't work as expected, some pieces keep giving size problems (usually too small now) $\endgroup$ Jan 12 '18 at 14:59
  • $\begingroup$ I changed it to the result from the calculator (80 steps per mm) but the extruder heater stopped working and I couldn't try it deeply. I am waiting for a new one, I will update this when I can do the tests. $\endgroup$ Jan 16 '18 at 7:47
  • 1
    $\begingroup$ I finally could try it and thanks to the calculator I could set the right steps per mm, I noticed too that the extrusor steps per mm I had set in the firmware were wrong, I had them in 98 and the default value is 158.8308. After changing these (X, Y and extrusor steps per mm) values the print size is the expected. Thank you $\endgroup$ Jan 24 '18 at 7:54
2
$\begingroup$

I finally solved it by manually adjusting the steps per unit in the printer firmware.

The process is easy just move the extruder to one position and draw two marks, one at the extruder position and another one 10 cm in the X axis from the extruder position then with Repetier or with the the printer controls move the X axis 100 mm, if the extruder stops after the mark reduce the steps per unit or increase them if the extruder stops before the mark, do until the movement matches both marks. Repeat for the Y axis.

You can see the changes I made to the firmware in my GitHub

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.