2
$\begingroup$

Disclaimer: I have read about this elsewhere but haven't found a solution.

Printer: Printrbot Simple Metal with heated bed

Slicer: Cura 15.04.6 (also tried Cura 3.1)

Printing software: Whatever Cura 15.04.6 comes with when printing from USB

The print goes well for the first couple layers then just stops. It stays heated, fan keeps blowing, but print has failed. Here is the error:

... Send: N19517G1 X47.047 Y59.035 E1574.00486*126 Recv: ok Send: N19518G1 X68.604 Y74.097 E1574.44219*122 Serial timeout while writing to serial port, trying again. Unexpected error while writing serial port: SerialException: 'WriteFile failed ([Error 22] The device does not recognize the command.)' @ machineCom.py:_sendCommand:565 Changing monitoring state from 'Printing' to 'Error: SerialException: 'WriteFile failed ...' Connection closed, closing down monitor

I have gotten this using Cura 3.1 to slice as well as Cura 15.04.6 (though the error above was using the Cura 15.04.6). I've tried using a different interface for printing, but nothing helps.

Any ideas on solving this? I feel like I am missing a small but simple detail here to making it work.

[Edit] Added printing info at top to make it a little more clear what I was using.

$\endgroup$
  • $\begingroup$ What printer? what generate the error? what have you read? why what you read does not solve the issue? what other information do you want that was not available there? $\endgroup$ – mac Jan 12 '18 at 7:37
  • $\begingroup$ Excellent questions, first two answered in the edit. As for what I have read and why it didn't work, you know those times when you read so much and try so much that you forget what you've even read and tried? That's the case here. As for what else I want, honestly I just want to start printing again, and I couldn't find solutions to let me do that elsewhere (I'm sure the solution is out there, just didn't find it). $\endgroup$ – Yatalia Jan 12 '18 at 15:10
1
$\begingroup$

From the look of it, and given that you already two different slicers, it look like this may be a hardware issue. I have had very similar error messages with my cheap Chinese printer and this is ultimately why I ended up always printing via the SD card and stop worrying.

That said, the error is about the serial connection over your USB cable. I was about to write a list of suggestions, but I found out that your manufacturer already has a troubleshooting guide for your printer here.

Adding my own suggestions to those of Printrbot, this is the final troubleshooting guide (the linked page has detailed instructions for each step but 6 and 7):

  1. Cycle power
  2. Update your Operating System.
  3. [Windows users only] run a VCP (Virtual Com Port) driver wizard
  4. Check physical connections and swap power and usb cables.
  5. Use a standard 2.0 USB input rather than USB 3.0, if applicable
  6. Make sure that your printer is away from any potential source of EMI (Electro-Magnetic Interference). Microwaves ovens, many types of energy-saving lamps and power bricks/adapters are known offenders.
  7. If possible, reduce the serial speed of your connection (revert if this does not solve the issue, as it may effect print speed and quality).
  8. Flash your Printrboard

To clarify what these tips are all about:

  • Step 1 is about making sure you don't have your computer and printer in "dirty states" (as in: with their serial buffer corrupted or stuck).
  • Step 2-3 are about making sure you have as many known software bugs and problems patched as you can, as well as all the latest features. This is especially important if you are asking for help, as nobody is going to downgrade their own machines just to replicate a user' unique state.
  • Step 4-7 are about diminishing the possibility that the signal in your cables gets disrupted and mangled along the way between the computer and the printer.
  • Step 8 is like 2-3 but for your printer firmware, rather than your computer software.
| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks so much! I'll give that a try when I get home and hope for the best. $\endgroup$ – Yatalia Jan 12 '18 at 17:14
  • $\begingroup$ I tried using the SD card option way back when, but it didn't work for whatever reason (it was probably just heating up and I didn't know it, I was very new back then). Tried going with the SD card option again, and boom. Success. Not sure what the issue was, but whatever it was, it is gone when using the SD card. Thanks again! $\endgroup$ – Yatalia Jan 13 '18 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.