4
$\begingroup$

Anet A8 printer, Github Marlin, Repetier Host, Cura slicer

Just setting up printer and printed 20mm calibration cube from Thingiverse. X,Y,Z & E not too far off but not quite right (centre hole was oval not round) X19.5mm, Y19.5mm & Z20mm.

Followed Youtube calibration help and updated firmware to Marlin. I ran several iterations of request travel, measure result and tweek stepper settings (M501,M92xxxx, M500) Live Die Repeat...

When I now print the calibration cube I get X25mm, Y20mm & Z19.5mm.

Could the issue be with the firmare being upgraded to Marlin? The cube was sliced by Cura and I have used the same file for all of the prints. When I stop the print and ask Repetier to move the steppers the distance is as they should be for a 100mm travel.

$\endgroup$
1
$\begingroup$

If you have a stock printer, your calibration values should be stock - i.e. 100 steps/mm for X/Y. Also, as an extra hint, X and Y steps should be identical since the mechanics are identical (unless you swapped out one of the motors or drive gears).

It sounds like you have Y correct, but something wrong with X. This could be the belt being damaged, or slipping (or having slipped during your initial cal, and not later). Try increasing/decreasing print speed, this might show up some dynamic problems with the movement.

If you print something bigger (like this) you don't need to worry so much about measurement precision and under/over-extrusion (which adds to the error, but doesn't scale with size).

You don't make it clear if you've started by calibrating your extruder. This is the most important first step, and ensures that you extrude the right length of filament during the print. All this requires is that you mark out 10cm of filament and extrude it into free space.

$\endgroup$
10
  • $\begingroup$ It was the different answers from printer and configuration.h that I was questioning. Sorry if I was not clear. All the other variables I can tweak/deal with, but not knowing which settings are in charge it is hard to see what to change. $\endgroup$ – Plodmore Jan 29 '18 at 20:47
  • $\begingroup$ In that case, I don't understand your question. $\endgroup$ – Sean Houlihane Jan 29 '18 at 22:16
  • $\begingroup$ Bear with me. I noted the values of XYZE in the fi $\endgroup$ – Plodmore Jan 31 '18 at 17:42
  • $\begingroup$ Sorry, tinterweb dropped off twice. The question is why the steps/mm in configuration.h are not the same as the printer reports. $\endgroup$ – Plodmore Feb 1 '18 at 14:21
  • $\begingroup$ Eeprom values, I assume. $\endgroup$ – Sean Houlihane Feb 1 '18 at 14:30
0
$\begingroup$

There could be a number of issues causing this.

Since you just set it up here is a list of questions for you to go through:

  • Are your belts tightened? (With an additional belt tightener)
  • Are your carriages are sliding smoothly?

Both might cause some irregular movements explaining the results being off.

Having said that, I wouldn't worry too much if you're <0.5 mm off. This is still a cheap DIY printer (I have the same one, by the way).

This video actually goes into some details why you shouldn't worry so much about 100% accuracy and what you should actually care for when tuning your printer: https://m.youtube.com/watch?v=Mbn1ckR86Z8

Also Not sure how you measured the cube but callipers are often also not that reliable.

$\endgroup$
5
  • $\begingroup$ "callipers are often also not that reliable". Quotation needed. All tools come rated for an error margin, calipers are typically accurate to 0.05mm. $\endgroup$ – mac Jan 28 '18 at 22:36
  • $\begingroup$ That's true but with 3d printed objects your walls can be inconsistent so depending on where you measure or how hard you pressed when measuring can affect the readings. $\endgroup$ – Gekko09 Jan 29 '18 at 18:54
  • $\begingroup$ measurement error is not the same than instrument accuracy though. Calipers are accurate, but as any instrument, the operator needs to know how to use them! :) $\endgroup$ – mac Jan 29 '18 at 19:26
  • $\begingroup$ Ah good point 😊 $\endgroup$ – Gekko09 Jan 29 '18 at 22:57
  • $\begingroup$ All good points however it doesn't explain why uploaded configuring $\endgroup$ – Plodmore Jan 31 '18 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.