6
$\begingroup$

I recently rebuilt my A8 printer to have a metal frame and replaced the board with a GT2560 reva+. I'm having problems with the temp readings from both my hotend and hotbed. Using marlin 1.1x and Its possible I have something configured incorrectly. I can get successful prints with good quality but sometimes I get thermal runaway during a print.

Both cold and at temp (200c) have fairly large temp spikes. I didn't have this problem with my old board. I had much smoother temp curves. I'm using the default PID values for Ultimaker Kp 22.2, Ki 1.08, Kd 144.

I have tried to use PID autotune but get drastically different values every time I run it and using the results gave worse results (sometimes giving a heating error during the autotune). I checked all the wiring and nothing looks frayed or damaged.

First pic is cold temps. Second is trying to do a PID tune. Third and fourth are during a print.

Temps cold

PID tune

During a print

During a print 2

$\endgroup$
1
  • $\begingroup$ Are you sure the fourth is during a print? Looks like PID auto tune to me. $\endgroup$
    – Valmond
    Feb 14, 2018 at 9:08

2 Answers 2

2
$\begingroup$

I had a similar problem and there could be three reasons(if the connections are ok):

  • thin wires to the hotend
  • one of the MOSFETs was fried
  • the termal sensor wasn't good enough insert into the hotend

Try to measure the hotend heating element voltage while printing.

$\endgroup$
1
  • $\begingroup$ One of the mosfets on the board was bad. Just replaced the board and the problem was solved. $\endgroup$
    – B.Schoch
    Feb 24, 2018 at 16:34
1
$\begingroup$

This really looks like a bad connection, so try with your old board to see if the broken connection is on the board, or it's the temp sensor or the wires.

I had exactly this problem with a bad connection from the temp sensor.

If you didn't break anything, it's the board that's fried / badly connected.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .