5
$\begingroup$

As part of a project with my university, I have developed a new extruder to attach to a Prusa i3 MK2. My problem is that both the nozzle and PINDA probe have moved 17mm forward and 0.5mm to the right. As a result when I try and calibrate the printer it moves to the home position and the PINDA probe is too far out over the heatbed so it doesn't detect the printing surface. What is the simplest method of moving the home position so that the printer can be properly calibrated?

UPDATE: I am planning on removing the heatbed and placing spacers that will move the printing surface 17mm forward. This should then prevent the printer losing any printing area and hopefully prevents me having to edit any code. Can anyone see any problems with this I'm overlooking?

The simplest thing to do would be to move extruder 17mm closer to be the same as the original printer but my deadline is fast approaching and I haven't time for a redesign that large.

$\endgroup$
  • $\begingroup$ This may sound stupid (it does to me, but...), but: move the X and Y limit switches by the same distances. Keep in mind that, as fred.u points out, you will want to offset the max travel limits so that the head never crashes into a hard stop. $\endgroup$ – Carl Witthoft Feb 21 '18 at 13:41
  • $\begingroup$ Hi Carl, yeah i was considering doing this but the PINDA probe wouldn't have enough travel to reach the back line of calibration points $\endgroup$ – Marc McKee Feb 21 '18 at 15:43
2
$\begingroup$

Consider the original installation with the orientation of the Pinda probe to the nozzle. Let's say for argument's sake that the Pinda probe is 3 mm to the right and directly in line with the nozzle on the y axis.

If you examine your new nozzle, I would expect that the relationship of the nozzle to the Pinda probe no longer matches the original spacing.

If possible, re-design the mount to place the Pinda probe in such a way as to match the original design.

Thanks for pointing out my oversight, Mac. If the relative position of the nozzle and pinda probe are as the original, the solution is then in changing the appropriate parameters in the firmware.

I found a reference for someone who had a bit smaller error in home position, but the concept is the same.

The link above points to information reading thus:

In Configuration_Prusa.h:

Code: Select all // Home position

define MANUAL_X_HOME_POS 0

define MANUAL_Y_HOME_POS -2.2

define MANUAL_Z_HOME_POS 0.15

// Travel limits after homing

define X_MAX_POS 250

define X_MIN_POS 0

define Y_MAX_POS 210

define Y_MIN_POS -2.2

define Z_MAX_POS 210

define Z_MIN_POS 0.15

it will be necessary to connect the printer via USB to a computer running an Arduino IDE and to load the Prusa specific files for that printer. Edit the noted location, save/write the configuration and test.

I would suggest small adjustments in only one or two parameters at a time, to avoid ambiguity in the cause/result sequence.

$\endgroup$
  • $\begingroup$ I understand the OP to say the relationship hasn't changed ("both have moved..."). ...or maybe I am misunderstanding your point? $\endgroup$ – mac Feb 20 '18 at 21:11
  • $\begingroup$ Thanks for the answer! I've no experience at all editing code but I'll give it a go. The distance between the PINDA probe and the extruder has remained the same $\endgroup$ – Marc McKee Feb 21 '18 at 12:17
  • $\begingroup$ IIRC, Cura has settings that will define those min/max and zero offsets for you. $\endgroup$ – Carl Witthoft Feb 21 '18 at 13:38
  • 1
    $\begingroup$ @CarlWitthoft - those settings are used for producing the gcode, here the problem is likely to be the self-calibration routine ran by the firmware. $\endgroup$ – mac Feb 21 '18 at 21:10
-1
$\begingroup$

What is the simplest method of moving the home position...

I think the solution outline by @fred_dot_u is very elegant, so I would go with it.

...so that the printer can be properly calibrated?

I'm not sure that will be possible.

Because the physical lenght of the axis hasn't changed, by moving the nozzle/probe, you have actually reduced their reach in the opposite direction, so the probe may be unable to travel on top of the intended calibration points (the usable printing area has also shrunk, but that's less of a problem).

If that is the case, I can't think of an easy solution (bar not using the auto-calibration feature altogether).

$\endgroup$
  • $\begingroup$ this is more of a comment. $\endgroup$ – Carl Witthoft Feb 21 '18 at 13:38
  • $\begingroup$ @CarlWitthoft - Can you articulate? My intent was answering the question "how can I have the printer calibrating correctly?" with an explanation on why this may not be possible... but I'd be happy to be educated on any rule I may not know about posting answers! :) $\endgroup$ – mac Feb 21 '18 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.