3
$\begingroup$

https://photos.app.goo.gl/O6yPf3sDeV1yhS0C2

I tried to illustrate my problem in the videos above, two of them show the weird movement and the other shows me clicking on the home button repeatedly.

Some Info:

  • Marlin 1.1.8 or 2.0.0 (same problem in both)
  • Robotdyn RAMPS 1.4
  • 0.9 angle stepper motors
  • DRV8825 drivers configured at 0.8V Vref
  • Anet A2 Plus stock for all the rest
$\endgroup$
  • $\begingroup$ is that freshly assembled device? $\endgroup$ – profesor79 Mar 26 '18 at 16:09
  • $\begingroup$ It might be helpful to know which are the result of a single movement command, and which is the response to successive home requests. $\endgroup$ – cmm Mar 26 '18 at 17:37
  • $\begingroup$ It might be helpful to know which are the result of a single movement command, and which is the response to successive home requests. Some words about what is weird could help, so that an answerer needn't access the video (although the video is great information to attach to your question). From the video, it looks like movements on two axes are not coordinated -- only X or Y moves, but not both at the same time. I won't try to answer your question, but your observations will help bring the right answer. You are closest to the problem, and have eyes, ears, and fingers on the problem. $\endgroup$ – cmm Mar 26 '18 at 17:42
3
$\begingroup$

As far as I can see on the attached videos your homing movement is reversed. as per Marlin, the homing for X shall move towards the left side and for Y to the back of the printer.

That could occur when: cable connectors to stepper motors are reversed, or the motor is assembled the other way (you can set reverse direction in Marlin)

The other issue is steps/mm calibration need to be done see source below.

The high pitch in the video could also point that the drv8825 is shutting down the movement as it is overloaded.

please also check that for vref

Configuring Vref In order to measure Vref you first need to turn on your printer as you normally would. If you only connecct using USB, but not external power, you get a wrong reading.

You need to turn on your multimeter and set it at 2v. Put the red one on the potentiometer and the Black one on the Gnd pin. Both are marked on the images here.

Before starting this I read they come with a very high vref setting, and it is recommended to start around 0.5v Vref. After measuring mine, I can confirm they come with a very high initial setting. Mine both came at 1,65v or so! - Yours might be different, which just underlines the importance of doing this.

Contrary to normal potentiometer usage, the ones on most copies/clones of DRV8825 are lowered by turning clock-wise, so that is what we will do, to we hit 0,5v on each. - A quarter of a full turn lowered it to 0,7v, - after that it goes very, very rapidly down, so aim for the quarter of a turn + a tiny tad more. If you buy your DRV8825 directly from pololu.com the Potentiometer are dialed up by turning it clock-wise:

source

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi, I've just solved the problem, I found out that the logic of my endstops are reversed. That solved everything. Yes, I have to tune the steps per mm yet. However my Extruder motor does not move, even above extrusion min temp $\endgroup$ – G-Pereira Mar 27 '18 at 17:04
-2
$\begingroup$

The problem was the logic of the endstops that were reversed

| improve this answer | |
$\endgroup$
  • $\begingroup$ You would be better to accept the other question rather than add such a short answer. $\endgroup$ – Sean Houlihane Mar 28 '18 at 13:27
  • $\begingroup$ This is not a matter of effort but instead it is a matter of what's right or wrong. The other post is really well written but it doesn't address the problem faced. $\endgroup$ – G-Pereira Apr 21 '18 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.