I am a novice to 3D printing and have encountered an issue that I cannot seem to solve. Hopefully someone here can point me in the right direction.

I have a Creality Ender 4 that I purchased a few months ago and up until about 4 weeks ago, it worked great. I had moved it from its original place and in doing so, something became amiss in the firmware as it would no longer heat up the print bed either manually or by sending print commands via USB. The SD card slots would also give errors when trying to print from an SD card. So, after doing some research, I ended up flashing the firmware in hopes that it would reset any of the hiccups I was having.

This both did, and did not, work. I tried MK4Duo, but apparently there was no support for my auto bed leveler and the bed was coming up and hitting the nozzle tip when I tried to print. I switched and uploaded Marlin 1.1.8 which seems to have solved the non-functionality of the auto leveler, but it has caused a new problem that I just can't solve.

Now, when I try to initiate a print, the bed will not raise high enough. It stops, either when I set Z to home, or try to print, at about one quarter of one inch from the tip of the nozzle. Of course, at this point when the print starts, the extruded filament just comes out in mid-air like toothpaste and curls up all over the bed. I can manually push the bed higher to the point it needs to start at, but it still drops too low when I try to print.

I am comfortable enough in using Arduino to try to correct the problem in the firmware (if it is a firmware problem), but I'm just not sure where I need to look or what I need to adjust. If someone would be kind enough to assist me in tracking down some possible places to look, or what might be causing this, I would be extremely grateful! I want to be able to print again!

  • $\begingroup$ When homing, the z endstop must be reached. Does it reach the stop at the top? It is strange if the platform stops before the endstop on homing! Is this stop height adjustable, or does the stop touch a fine tuning screw (that has moved) on the platform? The thing is, you cannot close the gap when the endstop is limiting the platform movement. $\endgroup$
    – 0scar
    Apr 4, 2018 at 21:59
  • $\begingroup$ do you have auto-leveling? $\endgroup$
    – profesor79
    Apr 5, 2018 at 10:09
  • $\begingroup$ Interesting design! I like the X-Y carriage setup, but I'm concerned that all the support for the bed is along one edge. that seems guaranteed to lead to sag towards the far edge, and no way to compensate. If they put a second Z-drive (and guide rod) on the far edge, I'd buy one $\endgroup$ Apr 5, 2018 at 15:20
  • $\begingroup$ Thank you for the comments! Yes, I do have an auto leveler installed. It is functioning becasue when I manually push the bed higher the auto leveler will detect the bed when it gets close enough. If I leave it there though and go to the control panel and tell it to print from the SD card, the bed will drop back down to the previous position, about 1/4" below the nozzle tip. It won't raise back up to let the auto leveler detect it. The regular stepper for the Z movement isn't active since the auto leveler is plugged up in its place on the motherboard. $\endgroup$
    – dusodesign
    Apr 6, 2018 at 13:07
  • $\begingroup$ In moving the printer, either a wire was loosened/disconnected, or something shifted - Z-threads/screws turned, without the firmware/controller being aware, or the springs in the bed have changed level. Manually re-homing/re-calibrating should fix it. It's unlikely that in moving the printer the firmware changed. Does the new location the same "flatness" as the original? Was the original completely flat? Maybe the printer was calibrated for a slight tilt in the original location, and that tilt is no longer present. If you move the printer back to its previous location does the issue disappear? $\endgroup$
    – Greenonline
    Apr 18, 2018 at 18:36

1 Answer 1


Moving a printer would most likely affect the hardware rather that the software. Unless you have tinkered with the software over USB or loaded an unknown G-code file over SD card that has embedded G-code commands that change your settings.

The most likely solution is that the printer or parts of the printer shifted as such that the printer is not aligned anymore as it used to be. Re-calibrating the machine should fix that for you.

  • 2
    $\begingroup$ also: checking wiring should be the first step anyway. $\endgroup$
    – Trish
    Jul 23, 2018 at 18:14
  • $\begingroup$ @Trish,yes that should always be the first step, is everything well connected, thanks for the addition! $\endgroup$
    – 0scar
    Jul 23, 2018 at 18:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .