6
$\begingroup$

I have a problem with my first layer height. But lets start at the beginning:

I own a Tevo Tarantula Dual extruder printer with a endstop switch for Z axis. No Auto bed level. 0.4mm nozzle. Everything worked as it should. I home extruder with G28 command and level the bed using a piece of paper or a thickness gauge 0.1mm. In the slicer I set Initial layer height 0.2mm for layer height 0.1mm. The fisrt Layer looked perfect and sticked to the bed fine. a few days ago it stopped in the middle of a print, nozzle clogged. No problem i changed the nozzle to a spare one i had. It is not the first time i took it apart.

Here starts my problem: After everything was build together again i home the extruder with G28, level the bed and start a print with the same settings i usualy used to print. But either the first layer didn't stick to the bed at all or looks terrible. i tried to level the bed again and also tried to get it to work with playing with the settings. But with no satisfactorily results.

Here is is the part my Question starts: I noticed that the first layer is actually not at the same Z=0 if i use G28 to home and the Z0 it shows when i print a part. For example: Set G28 Level bed with 0.1mm thickness gauge. Then start printing with layer height 0.1mm and initial layer height setting 0.2mm

The result should be 0.1+0.1+0.2 =0.4 real layer height (if i also count the 0.1 layer heigth(not sure if this is correct)) the printer shows here a Z of 0.2 But if i meassure it, it is around 0.7mm thats way to much.

hope this makes my more clear

I am confused why this is the case after i changed the nozzle. Considering i leveled the bed the exact same way i did before and used the same slicer. The new nozzle is a little bit shorter but i made sure both nozzle of the dual extruder have the same height. I do not understand why this happens. Is there a way to reset the Z? I tried the M851 code but as far as i understand it, it i used for Auto-Bed leveling. It didn't work anyway, says unknown command.

I could work around the problem by adjust the endstop until it somehow works, but then if i want to level the bed and use the G28 code the nozzle would crash into the bed and that is not a satisfactory solution. Would it suffice to set a z-offset in the firmware? I don't have much experience on that area.

;FLAVOR:Marlin
;TIME:737
;Filament used: 0.351177m
;Layer height: 0.1
;Generated with Cura_SteamEngine 3.2.0
M190 S47
M104 S197
M109 S197
M82 ;absolute extrusion mode
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000
;Put printing message on LCD screen
M117 Printing...
;LAYER_COUNT:9
;LAYER:0
M107
M204 S2200
G0 F3000 X75.185 Y64.596 Z0.2
M204 S1750
;TYPE:SKIRT G1 F1650 X76.267 Y63.316 E0.06132

$\endgroup$
  • $\begingroup$ What is unclear (i.e. to me) is whether you did change the z endstop height after the nozzle swap. If the nozzle is shorter, the endstop should change (be lowered) as the gap would be too large; so move it down. Setting a software offset will not work as it cannot get passed the zero level of the endstop (unless you enabled that in the firmware, but should not do if it evolves a mechanical switch). Please note that the initial layer is 0.3 not 0.4, the normal layer height should be omitted. $\endgroup$ – 0scar May 21 '18 at 8:25
  • $\begingroup$ No i didn't change the endstop. Instead i moved the bed up to close the gap. If i use the G28 command it moves to Z=0. Bed is leveled in all corners and also in the middle and everywhere is the gap between new and old nozzle 0.1mm. If i start Print the gap now is drasticly bigger (0.7 mm). Adding all numbers Z shows 0.2 and the 0.1 when leveling should make 0.3 mm gap. But instead it is now 0.4mm higher. If i home it again with G28 and i measure the gap it is again the 0.1mm. $\endgroup$ – mithras May 21 '18 at 10:27
2
$\begingroup$

this is a common case in my TT.... Please check the y-carriage wheels - on the 2040 and 2020 profile. Mostly you shall find a little wobble on one of the ends, that introduces instability in leveling, so you could level it, home it and another level is needed. In my case, I decided to upgrade for dual-z drive - please see this

Another interesting Z upgrade: option two

We can observe z-wobble by watching the x-axis on the left side (no lead screw), it will have a little delay in response when moving up/down comparing to the other side.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ I checked all wheels. No wobble. If i home the level is ok repeatadly. $\endgroup$ – mithras May 21 '18 at 11:18
  • $\begingroup$ in that case could you post first 30 lines from g-code generated file? $\endgroup$ – profesor79 May 21 '18 at 11:20
  • $\begingroup$ Had time to do some more testing. I think you were right, the leveling is not the same if i move the Z-Axis up a little bit and then home again. Thats where the gap was coming from. Although there is no noticable wobble in any of the carriages. Thanks for the help. $\endgroup$ – mithras May 24 '18 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.