3
$\begingroup$

My Zortrax M200 has a skipping extruder motor, I’ve checked the seating of all connections and 3 different (electronic ribbon) cables and still can’t fix the issue. The gear is clean and have tried fresh filament.

  • Does anyone have any possible thoughts on why this happens?

The extruded motor will move in the desired direction and then skip back.

Loading the filament is fine. Tried new nozzles, blockages checked, etc.

$\endgroup$
  • $\begingroup$ What do you mean by cable? The electronics cable or the filament tube? $\endgroup$ – 0scar Jun 17 '18 at 15:26
  • $\begingroup$ @0scar the electronic ribbon cable. $\endgroup$ – James B Jun 18 '18 at 12:05
  • $\begingroup$ Is it skipping as in "no gear motion when it should be extruding" or as in "gear moves but filament doesn't move" ? Radically different situations. $\endgroup$ – Carl Witthoft Jun 18 '18 at 15:13
  • $\begingroup$ @CarlWitthoft it rotates and then skips backwards. Loading filament is fine. Tried new nozzles, blockages checked, etc. $\endgroup$ – James B Jun 18 '18 at 15:31
  • 1
    $\begingroup$ Could you update the question as requested by @CarlWitthoft? This makes the question more clear on which issue to focus. $\endgroup$ – 0scar Jun 18 '18 at 19:04
1
$\begingroup$

Every time I've had an extruder "skip", it was actually because some condition was causing excessive back-pressure. Either the hot end isn't hot enough, the nozzle is too close to the bed, or something has clogged the nozzle.

If there is a "skipping" noise, then this is almost certainly the problem. When a stepper can not advance, the magnetic field will continue to "step". After the rotor is behind the steps by 180 degrees of field phase (which might be only a fraction of a degree os stepper motor shaft rotation), the rotor will snap back to re-align with the magnetic field. The sudden movement of the rotor and the release of compression on the filament often makes a loud clicking or thumping noise. If you can see the gear, it will jump backward and then rotate slowly forward before jumping backward again.

To see if it is the drivers, try extruding with no filament, or if you can, try moving filament through the extruder. If it doesn't move at all, or doesn't move under light drag, it may be the driver, the wiring, or perhaps the motor.

| improve this answer | |
$\endgroup$
  • $\begingroup$ This seems like a really good trouble shooting idea. I’ll give this a shot tomorrow. Thanks! $\endgroup$ – James B Jun 18 '18 at 18:57
0
$\begingroup$
  1. Check the pins on the motor. Are they bent? If yes - straighten them out with a screw driver.

  2. This could be a stepper driver problem. If it is then bad luck. Zortrax hard solders their stepper drivers onto their control board (this sucks and is a pure monetization related move by them).

This results in you having to get a whole new set of connector cables and or new control boards every time something goes wrong.

Ask for a control board replacement with new connector cables, if your machine is still under warranty it should be free of charge.

Switch to different or cheaper machines like Wanhaos or Ultimakers if you want the same ease of use and cheap part replacement.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.