4
$\begingroup$

I have just assembled the Creality3D Ender-4 kit a couple of days ago. I completed some rewiring and everything seems to be wired correctly, I'm able to auto-home successfully, but this is the problem I'm having:

I tried printing a calibration cube. The first problem I noticed is that the printing is starting on one corner instead of the center as specified on the Printer Settings in CURA (check settings below).

Second problem is that I'm getting significant distortion. The movement of the printer seems to be fine, no jerks of weird sounds. I tried all I know but I honestly don't know how to proceed with this. I have a couple of hours of experience in 3D Printing so I'm completely lost.

This is the result I got (Model printed with Raft for adhesion):

Model printed with Raft for adhesion

These are my CURA settings:

Printer

CURA settings - Printer

Extruder

CURA settings - Extruder

$\endgroup$
  • 3
    $\begingroup$ Remove the tick mark of "Origin at center" your origin lies at front left. $\endgroup$ – 0scar Jun 20 '18 at 4:28
  • 4
    $\begingroup$ The "Origin at center" does NOT say that your print will be start in the center, it says that the homing point is in center. Since this is very uncommon for 3 axis printers, you should try to remove this tick like @0scar said. Also other information like Material and settings would be interesting to help you. $\endgroup$ – Horitsu Jun 20 '18 at 5:19
  • 2
    $\begingroup$ possibly helpful: makerware.thingiverse.com/groups/anet-a6-ender-2-dremel-3d/… $\endgroup$ – Carl Witthoft Jun 20 '18 at 13:27
  • 1
    $\begingroup$ @ Carl Witthoft : That helped a lot, its fixed now. I'll add the details as an answer below $\endgroup$ – Chepech Jun 21 '18 at 17:06
  • $\begingroup$ If you could post an answer then that would be great, thanks. Slightly off-topic but what I find to be a bit strange is that the Ender-4 does not appear on the Creality3D website. Is it really new, and/or have they just not bothered updating their website recently? Or is it a clone/improvement made by someone else? $\endgroup$ – Greenonline Jun 22 '18 at 16:22
4
$\begingroup$

The first problem is solved by removing the tick mark at Origin at center. Most printers have their origin at a corner (not Delta's, their origin is in the top center).

The second problem is a little more difficult to solve. Please note that a kit should be loaded with preset values that should be fair enough to print, your picture does not appear to print the calibration cube correctly, so you should try to eliminate each possibility one at a time. As said, your picture is not very clear, but it does not appear to be a cube, it looks more rectangular (also note that a raft is only interesting when printing difficult, read prone to warping, filaments like ABS).

What you could do is print simple squares (no raft, but use a brim or skirt), e.g. 50 x 50 mm (only 1 or 2 walls in width and a few layers high), and measure the printed size.

  • If these squares do not stick to the heated bed, calibrate the Z height to nozzle distance and re-level the bed or increase the heated bed temperature;

  • If the X and Y sizes are different, you should calibrate the steps per mm for the direction that differs (M92 is the G-code to set the steps per mm; M500 to store the value to memory; these codes can be given over USB using specific programs that interface through a command line interface e.g. Pronterface, Repetier-Host or OctoPrintor alternatively in a .gcode file and loaded through the printer user interface);

  • If extrusion does look weird, measure the filament width at various sections of the filament with a vernier caliper and calibrate the extruder stepper and set the correct amount of steps per mm;

  • Finally, print the 20 x 20 x 20 mm cube and measure the height and adjust the steps per mm for the Z direction.

| improve this answer | |
$\endgroup$
  • $\begingroup$ if you are using G-commands then it will be nice to tell OP how to issue them (proface, serial monitor etc) to the printer - what do you think? $\endgroup$ – profesor79 Jun 22 '18 at 9:09
1
$\begingroup$

Fix was actually pretty simple.

I just removed the printer that I had setup on CURA following the manual provided by Creality (found on the provided SD Card) and started from scratch.

The one that worked was actually setting up the printer as a Creality CR-10 and then just changing the XYZ dimensions. This setup has the Origin at Center option unchecked as suggested in the comments. That's all it took...

enter image description here

New results: enter image description here

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ You must have messed it up a little as what you describe what you did you normally would not get this much improvement! $\endgroup$ – 0scar Jun 25 '18 at 18:45
  • $\begingroup$ @Oscar : The provided SD card comes with a preset intended for the Ender4 the manual indicates to use that, however what worked for me was to start from a CR10 preset and change the dimensions afterwards. Not sure why the warping was happening but that fixed the issue. $\endgroup$ – Chepech Sep 24 '18 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.