I finished the mount of my Anet A8, tested everything and apparently it was ok. I installed the driver that came with it, CH341SER_MAC, turned on the printer, connect USB cable, but nothing happened.

In Cura, I tried to add a printer many times and this message always appears

The printer isn't connected.

In OSX, I discover in System Information, an USB2.0-Serial, that I think can be the printer. Is it a printer driver problem? Is it the Cura setting? I'm completely lost...

OSX System Information - USB

  • $\begingroup$ check @Sevasuslik 's reply, the drivers were not the issue, Cura is. $\endgroup$ Commented Jan 1, 2022 at 12:56

4 Answers 4


There are a lot of problems with the CH340 chipset drivers to be found on 3D SE and various forums on the internet. To use this cheap CH340 chip that is used by a number of Arduino compatible (clone) boards to provide USB connectivity (a USB bus converter chip that converts USB bus signals to serial interface) you need to install a correct working driver.

For Mac OS X you can try to download a working version for the OS system you are using. You can try to use this driver installer or this driver installer. Both reported to work with Mac OS.

Edit: If you are using OSX El Capitan, please read this. To get the CH340 drivers to work you need to use the tool csrutil.

  • Reboot and press CMD+R immediately after hearing the startup sound to boot to Recovery Mode
  • Open Terminal
  • Execute the following command: csrutil enable --without kext
  • Reboot

More information is found here!

  • $\begingroup$ 0scar, do you think that I should delete my answer? It isn't El Capitan specific (because I hadn't read the question correctly), doesn't provide a definitive answer that works, and is quite long winded. I have turned it into an on-going blog instead. The OP hasn't returned to say what the solution to his issue was. $\endgroup$
    – Greenonline
    Commented Jul 2, 2018 at 15:05

You are using OSX El Capitan. The version of OSX is particularly relevant w.r.t. the CH340 drivers. A driver that works on one OSX version, will not necessarily work with a different version of OSX - even minor version changes of OSX can be affected (as the answers to Problem with serial driver for CH340G board demonstrate.

Important Note

Before installing any new drivers, it is always worth backing up the original file, just to avoid any unpleasantness later. For example:

sudo mv /System/Library/Extensions/usb.kext /System/Library/Extensions/usb.kext.old

I seem to remember having the same issue, not with a 3D printer, but just with a cloned Arduino board. I thought that I had written a lengthy blog about it but can't locate it at the moment (I will update this answer when I find it)1.

The CH34x ICs are infamous for their poor support on OSX. On Windows they generally fare a little better, and TBH it is probably well worth considering a WinTel option just to save yourself time, frustration and headaches...

Nevertheless, I think that I found this site to be useful, How To Use Cheap Chinese Arduinos That Come With With CH340G / CH341G Serial/USB Chip (Windows & Mac OS-X).

See also Compatibility between Arduino and Arduino clones:

The most annoying issue, and even then it is quite minor, is that a lot of Chinese clones do not use an ATMega for the USB and instead use a CH340G. These chips, while fine when connecting to a PC running Windows 7, have great difficulties with the drivers on OS X, and end up just not being recognised. It is possible to find a driver for the CH340G, but when I installed it, it immediately crashed the MacBook, upon plugging in the cloned UNO..!

This advice also proved to be invaluable, from Post #47 - Arduino in OS X 10.9 Mavericks - Serial Port Issues

For any others who haven't been able to solve this one yet: if, like me, you decided to go with the cheaper chinese kick off arduino clone boards and had problems similar to this one, please check the following forum post, as it solved the problem for me:


And another blog site that explains the whole process really simply for noobs like me:


Actually the dude has even mirrored the relevant driver that solves the problem without having to find it on an all chinese or all russian website!

Finally, I have just had a problem with an Arduino Nano and my Mac (running Mountain Lion). Using this link, Connect Arduino Nano with Mac OSX:

  1. Download the driver from url: link
  2. Extract and install file CH34x_Install.pkg
  3. Run the command: sudo nvram boot-args="kext-dev-mode=1"
  4. Restart the Mac.
  5. Replace the text -P{serial.port} to "-P{serial.port}" in 2 files: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr/platform.txt (1 instance) /Applications/Arduino.app/Contents/Java/hardware/arduino/avr/programmers.txt (4 instances)

However, this did not work for me, but I am running OS X 10.8.5 and the driver is meant for 10.9 (according to the ReadMe.pdf). My /System/Library/Extensions/usb.kext file remained unchanged (i.e. the date did not change), so maybe the installer will not work for 10.8.5.

I tried the second of 0scar's suggestions, but this didn't work for me either (on Mountain Lion): adrianmihalko/CH340G CH34G CH34X Mac OS X driver - The usb.kext file was never installed in /System/Library/Extensions/ by either the 1.3 or 1.4 versions.

The first of 0scar's links, Signed Mac OS Driver for Winchiphead CH340 serial bridge, interestingly pointed out that, after installation (and the associated reboot), one may have to copy the usbserial.ktext file manaually to /System/Library/Extensions/`. So after locating the installed file I did the following:

sudo mv /Library/Extensions/usbserial.kext /System/Library/Extensions/usb.kext

and then rebooted once again.

Note the change of the filename - this may or may not be necessary. Either way, when I used both usbserial.kext and usb.kext, yet again, this did not help me on Mountain Lion. However, the documents do state that this particular driver is for 10.9 (Mavericks) through to 10.13 (High Sierra).

The answer to this question, Uploading to a CH340 “Nano” board using a Mac with Osx High Sierra, may help you on OSX High Sierra.

It might be worth trawling through this list of questions on the Arduino.SE site: osx nano, such as this one Rename device name (ch340 usb to serial) Mac OS.

Additional note

Another pitfall is that some drivers may be named CH341xx.xxx, but they may work for both the CH340 and the CH340... then again, they may not. The docs don't always say whether they will or not work for both ICs.


1 I think it might be this Re: Arduino in OS X 10.9 Mavericks - Serial Port Issues:

Yes, I have been struggling for a month or so, and finally realised (after reading http://forum.arduino.cc/index.php?topic=198539.15#msg1720630) that other chips were being used, in lieu of the FTDI chip, for example the Prolific 2305. After inspecting the board with a magnifying glass, I saw that I did not have an FTDI chip in my Chinese clones of an Uno and a Mega, but a CH340G instead.

Once I realised that I found the http://wch.cn/product/CH340.html site, but the Mac driver doesn't appear to be there. After a bit more googling I found the kiguino site. I downloaded the mirrored driver, rebooted the mac, and when I connected the Uno, my MacBook died and restarted with the grey serious error screen and refused to boot. After disconnecting the Uno, the Mac rebooted as normal, so no lasting damage done, but I am a bit wary of trying to plug the clone in again.

Anyway, note that the chip says CH340 on it, but the drivers are CH341. I assume that they are compatible.


The problem is not in drivers! In the file located at Ultimate Cura -> Contents/Resources/USBPrinting/AutoDetectBaudJob.py in line 74 in the if statement you should replace and with or:

if b"ok" in line or b"T:" in line: # or instead of and

What Cura version do you have? Cura only works with the Anet A8 via USB on versions 2.3 and lower according to this page. The page is from thingiverse(A 3d printing forum + print files page)

  • $\begingroup$ Link answers are not answers. $\endgroup$
    – Trish
    Commented Dec 27, 2018 at 18:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .