5
$\begingroup$

I have an Anet A8, and recently updated the firmware to Marlin 1.1.8. My only change was replacing the configuration files by the Anet A8 sample files built in with the firmware zip file.

Everything works fine but, sometimes, right after finishing a printing (while doing the "home all"), the LCD shows some weird data, like this:

LCD weird data

The same happens when push the "confirm", after the mesh bed leveling.
I'd like to know why it happens. Is it a Marlin bug?

$\endgroup$
  • 2
    $\begingroup$ Welcome to 3D Printing! I take it you have to reset the printer in order to get it to clear? $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Jul 4 '18 at 21:52
  • $\begingroup$ Just active the menu display, the best solution is to shield your shield, Gianluca has part of the solution $\endgroup$ – Fernando Baltazar Aug 28 '18 at 6:49
5
$\begingroup$

This is a known problem of the Anet A8 display, it is caused by electrical interference. Pressing the middle button will refresh the display.

This is prone to happen when doing long prints.

There are some reported successes of people inserting ferrite beads or toroidal rings.

No, this is not a firmware issue, this is a hardware issue.

$\endgroup$
  • $\begingroup$ My first though was about the Marlin because with the original firmware it never happened. So, I'm guessing now it was pure luck. Pushing the middle button indeed refreshes the display, except for the first character, that remains messy. $\endgroup$ – elias Jul 5 '18 at 0:09
  • $\begingroup$ Yes, this happens with unprotected shields and when we use a kind of polyester cloth and we are so close to the drivers. So be aware to avoid to use this kind of cloth, use cotton clothes. $\endgroup$ – Fernando Baltazar Jul 5 '18 at 3:15
  • $\begingroup$ @Elias Maybe pulling the flat cable from the sockets and re-inserting the plugs helps. Also keep the flat ribbon cable away from the 12V wires. $\endgroup$ – 0scar Jul 5 '18 at 6:14
  • $\begingroup$ Worked for me! Easy fix, just used on old ferrite ring and looped the display wire through it! $\endgroup$ – Felix Aug 27 '18 at 14:39
4
$\begingroup$

I have solved completely, I covered the flat cable, with copper tape, this shield should be connected to the 0V of the power supply. All disorders will disappear.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.