7
$\begingroup$

I made a few successful prints since I got my CR-10 two weeks ago and I didn't run into any major trouble. The printer is new.

Today I set it to "preheat" mode while I was preparing the SD card with the settings being 210°C for the nozzle and 60°C for the bed. When I wanted to start the print I noticed that the temperature showed as "actual temperature" on the printer's screen showed 233°C and it was going up steadily while the "requested" temperature was still 210°C.

Thiking it might be a mis-manipulation on my part I powered it down for a few minutes (I got scared by the high-temp) and then powered it back on. I then immediately requested the print to start. The CR-10 heated up to the proper value, started printing and kept heating the nozzle. I stopped it at 217°C.

I looked for an answer on the internet but all I could find is people having trouble with the nozzle not heating at all ...

$\endgroup$
  • $\begingroup$ Hi and welcome to 3D Printing.SE! How did you measure the "actual" temperature? E.g. using an external thermometer, thermistor, thermocouple or a pyrometer, or read from the display? Maybe you could add that to the question. $\endgroup$ – 0scar Jul 19 '18 at 6:14
  • $\begingroup$ Thank you for your advice. I updated my question. The "real" temperature is measured by the printer itself and is displayed on the printer's screen. $\endgroup$ – Mathieu VIALES Jul 19 '18 at 6:48
  • $\begingroup$ Does this happen at lower temps, e.g. 195 (which is sufficient for most PLA filaments)? $\endgroup$ – Carl Witthoft Jul 19 '18 at 14:50
  • $\begingroup$ If you know them, post the firmware version and control board type/version, etc. $\endgroup$ – Carl Witthoft Jul 19 '18 at 14:51
  • $\begingroup$ Have you found & fixed the problem? If any of the answers helped you to get an answer to your question or come to your own conclusions then please do vote & accept an answer (using the tick button next to it). This helps us reduce the unanswered questions list & stops the question from being bumped once in a while. If you found another answer (than those already posted), please add that answer (& accept after 48 hours) to share your experience with the community. If you have not been able to address the problem please update your question. $\endgroup$ – 0scar Sep 11 '18 at 19:51
2
$\begingroup$

This is not an easy one to solve, the firmware of the printer should be keeping the printer at a certain temperature depending on the temperature setting and the current value. If the firmware is not able to keep the temperature at the requested level, but goes beyond that level, that could be considered "strange". As it measures the temperature (and reports it on your display) it must know that it is over the limit and thus should not power the hotend.

In this process there are a few possible candidates for you to look at:

  • Check for a faulty MOSFET (sort of an electronic switch) on your controller board (is it leaking current to the hotend?).
  • Check and or update the current settings for the PID values (settings for the control loop of the hotend). The PID values control the overshoot of the temperature. E.g. is this is very large overshoot? When incorrectly configured the temperature can get higher, but normally should never increase to infinity, are you sure it keeps rising? The determination of the new values is called PID tuning. Important commands (that need to be send over a USB connected printer with a 3D printer terminal application like Repetier Host, OctoPrint or Pronterface):
    • The M503 G-code command shows the current settings (somewhere in the heap of all settings).
    • The M303 G-code command can determine the values.
  • Reflash the firmware
  • Replace the printer controller board

You could replace the thermistor and the heater cartridge (just to be sure, most definitely not the problem, but they are really cheap to replace). The thermistor works as it reports the temperature, and the heater element doesn't get powered by itself.

As suggested below the most likely candidate for your problem is the MOSFET. These are pretty easy to replace (depending on your board) or replaceable by an external MOSFET module (if you happen to have one lying around).

$\endgroup$
  • 1
    $\begingroup$ I would suggest checking the MOSFET first, as this is the most likely explanation in my opinion. Measure the voltage on the gate. If it changes when the temperature setpoint is exceeded, but the heating does not stop, then the MOSFET is fried. Another good thing to check would be whether it starts heating without any input. I don't think replacing the thermistor or heater cartridge is a good recommendation (a broken heater cartridge certainly wouldn't heat up the hotend without power being applied to it). $\endgroup$ – Tom van der Zanden Jul 20 '18 at 10:01
  • $\begingroup$ As far as I know, the MOSFET is only related to the heating bed. I couldn't find any schematics nor any obvious pointer to where the nozzle's power command components where. With a friend of mines we tested (multimeter) a few components such as the thermistor and the heating resistor just "to be sure" (we didn't really know where to go). Everything is ok. We flashed the firmware and installed Marlin (latest version). Nothing changed. So I'm going to order a new board. I don't have enough knowledged of the board to try and fix it and can't find any schematics for it online. I'll let you knopw $\endgroup$ – Mathieu VIALES Oct 29 '18 at 15:50
  • $\begingroup$ @Wndrr Both the connectors for the heated bed and the hot end have a MOSFET attached; this is because the micro-controller cannot handle high currents, instead the low current connection to the micro-controller schedules the high current loop (like a gain) to the hot end cartridge. If there is a failure in the MOSFET, current may leak continuously. So did you measure the voltage over the cartridge during overshoot? $\endgroup$ – 0scar Oct 29 '18 at 19:01
  • 1
    $\begingroup$ I've repaired the printer a while back, but I forgot to update this thread. I tried everything but ultimately changing the motherboard was what solved the problem. I suspect I might have burnt something by heating both the bed and nozzle at the same time from a cold start. That's my best guess at why the MB failed. Thanks for your help ! $\endgroup$ – Mathieu VIALES Mar 21 at 13:36
  • $\begingroup$ @MathieuVIALES Many thanks and nice to come back after a while and report that you fixed the problem by replacing the board! The MOSFETor the pin/port scheduling the MOSFET are definitely suspects on your old board and certainly could have been damaged. Have fun printing! $\endgroup$ – 0scar Mar 21 at 13:40
-1
$\begingroup$

A similar condition occurred in my 3D printer. I solved the same. I checked all my connection and I came to know that I connected the thermistor of the extruder in the wrong port. So just check the connection of your thermistor.


Actually my 3D printer circuit board frequently failed because of over current. I then added a multimeter in series with my power supply and the load, also a voltmeter across the voltage regulator. I then corrected every motor driver DRV8825 to a reference voltage of 0.6 V so that the maximum current supplied to each of the motor will be less than 1 A. All these made my circuit checked ok. Then I uploaded the G-code, but I couldn't print because my extruder gets heated about 280 °C and got reset and suddenly shut down the extruder supply. This continues to happen.

Then I reinstalled the Marlin firmware and I also changed the port of my thermistor. Now my 3D printer is ok and prints nicely. I also faced another problem while I gave the print command - it showed that the extruder and bed had started heating but it actually was not heating. So I reinstalled the firmware again and this fixed it. Now my 3D printer works OK. You just try for these steps:

  1. Check the connection.
  2. Reinstall the firmware.
  3. Try manually preheat the extruder, and just see whether it heats to infinity.

These are my working experience please try for these, I think it will help you. Just don't leave it you will get the solution. Keep on trying.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.