4
$\begingroup$

I use Cura for creating the G-code files for my (2 1/2 year old) Prusa i3.

I have to put the prints in the corner furthest from the X-Y-Z origin symbol as the machine prints in the middle of the bed. How do I remove this offset?

$\endgroup$
  • $\begingroup$ I am pretty sure it is something in the cura config. Can you check that out by testing with another slicer, for instance slic3r? $\endgroup$ – Gunslinger Jul 22 '18 at 11:43
  • 2
    $\begingroup$ Hi Phil and welcome to SE.3DPrinting! If you would please add an image of your printer settings, that would be a great help for others to find the problem. I'm also pretty sure it is in the settings. $\endgroup$ – 0scar Jul 22 '18 at 12:03
  • $\begingroup$ this happened with my cr10 because i had the bed size set incorrectly. $\endgroup$ – dandavis Jul 26 '18 at 18:27
3
$\begingroup$

Not being able to see your settings, or your G-code, it is difficult to say. If it is slicer settings related, a common mistake is that the "origin at center" option is active. You should remove the tick mark at "origin at center" in the printer settings of the printer profile you use in Ultimaker Cura. Your origin is not in the center, it is left-front.

Another possibility is that the offset of your printer origin is way off. To check that you should connect the printer over USB and use programs as Repetier host, Pronterface, etc. to instruct the printer to go to (0,0,0) and see where the head ends up. You can also do this by printing a G-code file with homing code (G28) and a movement instruction (G1 X0 Y0 Z1 F1500). If the head moves to the left front, you know the printer is correctly setup, and you should look at the slicer.

E.g. when M503 is send in a terminal to the printer over USB, amongst the output you can find:

...
Recv: echo:Home offset (mm)
Recv: echo:  M206 X0.00 Y2.00 Z0.00
...

When the X and Y values are high, this can also cause the printer to have a large offset.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I've checked the Origin at Centre and it isn't ticked. Also downloaded Slic3r and tried that but with the same result. I'm inclined to think the problem is with the machine settings $\endgroup$ – Phil Jul 22 '18 at 16:01
  • $\begingroup$ @Phil please add a link to the G-code or post the first 20 lines or so. Post is updated to your comments. $\endgroup$ – 0scar Jul 22 '18 at 19:49
  • $\begingroup$ I think I've broken it all together now. I updated the firmware through Cura. All the English changed to Chinese and now the display is just blank. I had a look at reinstalling the drivers but everything was in Chinese and I seem to remember that some built in software changed the default language on my computer to Chinese when I first had the printer. $\endgroup$ – Phil Jul 25 '18 at 20:44
  • $\begingroup$ Do you have a genuine Prusa i3? Those are pretty easy to flash new firmware on. $\endgroup$ – 0scar Jul 25 '18 at 21:41
  • $\begingroup$ It's not a genuine Prusa, it's a Chinese clone on got cheat on Black Friday weekend nearly 3 years ago. It looks like a total fire hazard with all my home repairs but the only real problems have been the connections on the heated bed breaking and mismatched wiring when I've had to replace the extruder a f few times. I am currently awaiting delivery of another Chinese machine. $\endgroup$ – Phil Jul 27 '18 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.