I have recently got an MKS GEN L V1.0 board and 5 TMC2130s. (X, Y, two Z, E). I have wired it all up and uploaded Marlin 1.1.9 and after some quick troubleshooting I got the motors moving. Next day I tried it again and it gave me this error:

E0 driver error detected: overtemperature short to ground (coil A) short to ground (coil B)

with the following driver debug report: (notice that the extruder driver doesn't show up)

  X   Y   Z
Enabled     false   false   false
Set current 800 800 800
RMS current 795 795 795
MAX current 1121    1121    1121
Run current 25/31   25/31   25/31
Hold current    12/31   12/31   12/31
CS actual       12/31   12/31   12/31
PWM scale       10  10  10
vsense      1=.18   1=.18   1=.18
stealthChop true    true    true
msteps      16  16  16
tstep       1048575 1048575 1048575
threshold       0   0   0
[mm/s]      -   -   -
OT prewarn  false   false   false
OT prewarn has been triggered   false   false   false
off time        5   5   5
blank time  24  24  24
-end        2   2   2
-start      3   3   3
Stallguard thrs 8   8   0
sg_result       0   0   0
stst        X   X   X
Driver registers:   X = 0x80:0C:00:00
Y = 0x80:0C:00:00
Z = 0x80:0C:00:00

I did some research and found that you should change the CS pin for that stepper and so I did. I tried almost every available pin on my board but no luck. The only change I got was when I wired it to pin 11 and got this:

E0 driver error detected: overtemperature short to ground (coil A)

I have the Watterott TMC2130 SilentStep Sticks and have examined the board which seemed correct. Is all wired correctly. Tomorrow I will try to switch the driver to one from another axis and try to switch the stepper to see if anything changes, but it seems to me that it shouldn't since it worked for some time.

  • $\begingroup$ I will try marlin 1.1.8 tomorrow and the bugfix branch if that fixes my issue. $\endgroup$ Commented Aug 11, 2018 at 16:08

1 Answer 1


I have fixed it. I tried uploading the bugfix version of Marlin and no luck. Then I noticed a loose jumper wire that connected the driver to the board and when re-installing it I noticed it didn't grip the pin that strongly and could be easily pulled off so I switched the wire and everything works now. Turns out that even jumper wires can have a bad connection. Hope this helps someone.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .