4
$\begingroup$

I just bought an MKS gen v1.3, and everything on it works fine except for when I plug in the endstops. My X endstop works perfectly in every endstop outlet, but when I plug in my Z and Y endstops, the entire board loses power. Immediately after I unplug the endstop, the board turns back on. I've had these endstops for a while, so could it just be that the endstops are shot, or could there be something wrong with my board?

I'm using repetier firmware 0.92, as well as the latest release of repetier host software.

$\endgroup$
  • $\begingroup$ Have you tested the Y and Z axes' endstops with a multimeter (resistance setting)? $\endgroup$ – Greenonline Aug 18 '18 at 10:06
3
$\begingroup$

Have you tried plugging in the plugging the Z and/or Y end stops into the X position? This could tell you if it's actually the end stops or the board.

EDIT: Also, if the Z and/or Y end stops seem to work just fine in the X position, ensure you have the X position filled and try the other end stops in the Z & Y positions. It may be a case where having multiple positions on the board filled might be causing you an issue. This would point back at the board and not the end stops.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I had answered this at first suggesting to put the X end stop into the other positions, not realizing the OP had already tried that ... just suggesting testing the other way which could give you more data. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Aug 16 '18 at 16:50
  • $\begingroup$ If the problem's that the board cant supply enough current,it could be any part which is at fault and drawing too much current . $\endgroup$ – Sean Houlihane Aug 17 '18 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.