4
$\begingroup$

ISSUE: Stepper motors are not working when connected with RAMPS 1.4.

OBSERVATION: The LED lights(LED 2,3,4) in the RAMPS 1.4 is not powering up.

PRACTICES: I use Arduino Mega 2560 and installed Marlin firmware in it. And I bought a RAMPS 1.4 in a local electronic dealer. I placed the RAMPS over Arduino Mega 2560. For testing I just connected 2 NEMA 17 stepper motors with RAMPS. When USB port connection is given from laptop to Arduino board, a LED light is ON in Arduino board (L) and in RAMPS (LED 1). I use SMPS 12 V 20 A as a PSU for RAMPS. But in RAMPS the LED 2, 3, 4 are not switched ON. I checked the input voltage to the RAMPS using micrometer and it shows 11.75 V. But there is no output from the RAMPS.

Also I installed and tried Repetier firmware and Grbl but it doesn't work. And I use Windows 10 pro 64 bit OS.

When I flashed Arduino with Grbl, in this case all of the LEDs on the Arduino and RAMPS 1.4 are switched ON. I use Candle GRBL software to test the stepper motors.

And I replaced and tested with another RAMPS which is bought from Amazon but the problem remains unchanged.

Kindly give some suggestions at the earliest.

I have attached the images of my circuit connection:

i.imgur.com/k39rd7t.jpg

i.imgur.com/OPPuElQ.jpg

i.imgur.com/mM3BIEn.jpg

Board selection in Marlin:

#ifndef MOTHERBOARD 
#define MOTHERBOARD BOARD_RAMPS_14_EFB 
#endif 

Additional clarifications

In response to Professor's questions:

  1. Yes the stepper drivers are connected correctly
  2. Yes the stepper wiring is accurate (2B 2A 1A 1B) as per mentioned in the Ramps 1.4.
  3. No there is no voltage input to stepper motor. But there is 12V input to Ramps 1.4.
  4. Disabled cold extrusion
  5. No, the firmware is not set to no move before homing (issue G28 first)
  6. Yes, pins are set correctly for your board in Marlin
$\endgroup$
2
$\begingroup$

I actually thought the problem is in the electronic circuit but the problem is the baud rate. I initially took the baud rate as 115200 but later. after someone's suggestion, I changed it to 250000 and now it's fine.

| improve this answer | |
$\endgroup$
1
$\begingroup$

to help you to solve this problem - please see my checklist

  1. are the stepper drivers connected correctly (pin1 to pin1)?
  2. stepper wiring is accurate (1a-1a..2b-2b)?
  3. is there enough voltage provided to the steppers (regulate)?
  4. if you are trying to move E0 or E1 then you need to disable cold extrusion as that stops rotation (waiting for 170C deg on the nozzle)
  5. is the firmware set to no move before homing (issue G28 first)?
  6. are pins set correctly for your board in Marlin?

the led's are set on my ramps as they are mostly giving a stutus for heater fan and bed, so grbl software could use those pins differently

| improve this answer | |
$\endgroup$
  • $\begingroup$ New problem professor: After connecting all the motors in my 3d printer, I use pronterface to control my 3d printer. But now kindly tell me how to set limits and to move xyz axis in negative direction. My printing volume is 180mmx180mmx130mm. While using pronterface, when I select Home option for x,y&z axis it moves about 5mm in positive direction every single time. Sometimes it shows, 'Printer halted. kill() called'. How could this be solved? Thanks and regards Baalaji V $\endgroup$ – Baalaji V Sep 1 '18 at 6:11
  • 2
    $\begingroup$ @BaalajiV Comments are not meant to start a discussion or launch new questions - as previously stated this is a Q&A site and not a forum. Please open a new question and link back to this question! $\endgroup$ – 0scar Oct 12 '18 at 12:50
  • 1
    $\begingroup$ @BaalajiV - Please do not ask new questions in comments. Without wishing to sound harsh, StackExchange is a Q&A site, and not a forum of threaded messages. The reason for this is to aid the search for answers to issues, and provide it in a structured Q&A way. I know that this might seem a pain, but can you repost your question using the Ask Question link at the top of the page? When you repost your new question, please feel free to refer back to this original question using the URL, seeing as it is the reason why you posted in the first place. $\endgroup$ – Greenonline Oct 12 '18 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.