I sadly have a big problem since a couple of weeks and I cant fix it myself. For over 20 prints, I had the same problems: At the start, everything goes well but at some point of time, my Creality CR-10 starts under extruding and after like 1 minute, NO filament is extruded anymore and the 3D printer moves over the printing bed without extruding anything. After that, I have to pull out the filament and the feeder always grinds into it.

Some problem with the hotend (so the feeder works well but it cant push the filament through somehow - I cleaned the nozzle and couldn't find anything wrong there. When I push the filament through by hand it gets extruded but after a failed print, it is VERY hard to pull it back (because of the filament being slightly bigger at the nozzle - hard to remove! -

That could be the problem:

I just tried to remove the filament from the printer (another failed print) I had to use two tongs because the filament was so hard to pull back. I noticed that the diameter of the PLA close to the hotend was a lot bigger (way over 1.75 mm) For about 5 cm that's a very long distance - that's the reason why it's hard to pull back (and also push through?) But I don't know why that happens... If I get an answer for that, I think that I have solved my problem

I already tried printing at 50 % which didn't work.

  • Creality CR-10 with 0.4 mm nozzle,
  • 1.75 mm PLA filament used (white)
  • 0.27 mm layer height
  • 45 mm/s printing speed at 220° (I can easily push the filament through at 200° by hand)
  • 60° bed temp

And here some pictures of the failed prints:

Failed print

Filament grinding

Sorry for the bad resolution

Failed print #2

I think I can exclude these:

It could be: (the things I can imagine but don't have a solution for)

  • The feeder being too strong/my new PLA filament being too soft
  • Maybe a software problem? I'm using the newest Cura version and I don't know what could be wrong there.

The filament seems to run out of the hotend. Something is really broken here. I tried to lower the print temperature and don't have an issue (at least not that big) with pulling out the filament but instead, the feeder started grinding into the filament again.

Filament exiting nozzle

I'm very happy for any answer and possible solutions.

  • 1
    $\begingroup$ Check your extruder calibration, and also print a calibration cube at 100% infill. $\endgroup$ Aug 28 '18 at 19:27
  • $\begingroup$ If you have a fix, post it and accept it as the answer. $\endgroup$ Aug 30 '18 at 22:49
  • $\begingroup$ According to a deleted answer from @DinaldEnte, it was a loose spring. $\endgroup$ Sep 6 '18 at 12:52
  • 1
    $\begingroup$ @SeanHoulihane Sadly, this didnt fix the problem entirely. It appeared again later. Ill post the fix when I fixed the problem. $\endgroup$
    – DonaldEnte
    Sep 7 '18 at 13:03

Grinding is due to attempts to advance filament faster than it can be melted and dispensed. Try one or more of the following:

  • Raise the head temperature (to meet current throughput demand)
  • Lower the print speed (to reduce throughput demand)
  • Slice for thinner layers (to reduce throughput demand)
  • $\begingroup$ Should I print with a temperature higher than 220°C? That would be quite unusual for PLA.. And I will try to lower the print speed. $\endgroup$
    – DonaldEnte
    Aug 27 '18 at 13:40
  • $\begingroup$ For your material, you will need to adjust and observe. Perhaps 225°C is best for that speed. Perhaps 215°C at half speed works well. You must test with that material on that equipment. What works for me may not work for you. The slower you print, the more time the material stays in the melt zone of the head. $\endgroup$
    – Davo
    Aug 27 '18 at 13:43
  • 1
    $\begingroup$ I already tried printing at 50% speed and it still didnt work :/ I just dont know what else to try.. $\endgroup$
    – DonaldEnte
    Aug 27 '18 at 13:51
  • $\begingroup$ Please add that info to the original post so others will have that info. $\endgroup$
    – Davo
    Aug 27 '18 at 13:53
  • $\begingroup$ Alright. I changed the post, you might have a solution for it now? $\endgroup$
    – DonaldEnte
    Aug 27 '18 at 15:24

There are many reasons why that could be happening. The simplest one:

  1. The nozzle may be clogged/has debris. Push the filament down into the hot end with your hand to see if more force will cause a better flow rate. Also, if the filament tries to curl as it's coming out of the nozzle (in any direction) there is is most likely a blockage in the nozzle.

  2. There is a gap between the teflon tube and nozzle, resulting in a larger melt zone which makes it harder to push the filament through.

  3. The extruder cooling fan isn't working which allows the heat to travel up heat brake, extending the melt zone.

  4. The extruder gear may be dirty with plastic debris/dust/rust. This will cause slipping. The fact that the print starts working but then fails seems to indicate that the problem is progressive, indicative of slipping.

  5. The motor is under-powered, resulting in step loss and a cumulative error during printing.

  6. The filament is poor. Voids and inconsistent diameters used to be a problem that caused print fails long ago, but not so much these days.

  7. The stepper motor drivers are over heating and shutting down intermittently during printing, resulting in cumulative errors. Use a house fan/ or other suitable fan to cool the board. I had one Anet A8 mainboard die on me due to over heating.

  • $\begingroup$ Thank you for the answer. I think it is one of the things you mentioned. The prints started to fail since I bought a new PLA filament. Its diameter is perfectly consistent 1.75mm but its quite soft.. I bought a new Hotend and after installing it, the problem can only be the filament or feeder if its not working right? $\endgroup$
    – DonaldEnte
    Sep 8 '18 at 10:58
  • $\begingroup$ If plastic is now spilling out of the hot end then sadly you did what most newcommers do: You inserted the nozzle flush with the heat block, so you have no idea if there is a gap between the throat. This allows the plastic to ooze out between the threads of the throat and block. Don't thread the nozzle all the way down, flush to the heat block. I thread mine until the last thread just disappears. I usually use a piece of 0.5 mm metal to ensure that a gap remains. Then screw the throat in all way until it stops. Lastly, tighten the nozzle. $\endgroup$
    – user77232
    Sep 9 '18 at 2:25

I have had this problem for several reasons. I can not say what your reason is, but these have been mine. From your symptoms, I suspect the first problem, but I've listed others in case they are helpful

  1. I had this problem to most with a "Thing-o-Matic" printer. The problem was that there wasn't a clean enough break between the heater and the filament. To fix this, I added a fan on the metal tube above the melt zone. When the filament was sitting, it would soften and expand. It was then harder to push, and it would cause these vertical strings like you have in your picture. The Thing-o-Matic extruder was direct rather than Bowden, but the same problem could exist. I see that the CR-10 has a fan attached to the extruder. Be sure it continues to run, and that the airflow cools the region right above the hot-end, even when the head is an inch above the bed.

    One more thought on this topic: retracting pulls filament out of the melt zone into the space above the melt zone, bringing the heat with it. Lowering the retraction settings may reduce the heating of the space above the melt-zone.

  2. Bad connection to the heater, so that the temperature drops while printing.

  3. Too much pressure on the filament by the extruder pressure roller. One pass through is fine, but a pattern of short extrusions with frequent retraction caused the filament to pass repeatedly through the roller, and become flattened so that it had difficulty feeding through the rest of the mechanism.

  4. Jammed filament on the spool, preventing the extruder from smoothly pulling.

Some other problems which could cause this, and I have looked for but haven't been the problem in my cases:

  1. Weak power supply. Check the +12 or +24 voltage while the problem is occurring.

  2. Overheated or defective extruder driver chip that fails to drive one or more stepper motor phases with sufficient current. This can allow good behavior much of the time, but if anything happens that adds load to the motor, it can stop turning.

  • $\begingroup$ Thank you very much for your thoughts! Yesterday, I replaced the nozzle and my bowden tube so I can exclude a clog or something different. The next things I will try are 1) raising the temperature (and external measurement) 2) disabling ALL retraction settings and 3)fan on 100% .. if all of these things fail, the only thing left will be too much tension of the feeder on the filament (but I dont know how to fix this because I cant change it on my printer) I checked voltage etc. everything ok $\endgroup$
    – DonaldEnte
    Aug 28 '18 at 8:24

Under-extrusion after some time printing sounds like heat-creep. If the cold side of the extruder is getting warm, even up to 60°C (the glass transition temperature), then the un-heated filament will start to soften and fill out to block the tube. As this happens, there is more pressure above the hot-end and less extrusion (but even more force to make the situation worse).

sample clogged filament

The best solution to this is better cooling of the extruder/stepper, and a good heat-break with a sharp transition between solid and well-melted (but something has presumably triggered this failure on your setup, rather than a fundamental design problem).

Other things you could try are:

  • Less retract distance (to reduce the variables)
  • Lower print temperature (and speed, but this will increase pressure in the nozzle)
  • Reduce the extrusion multiplier (if your filament is a bit thick, the pressure might be a bit high)
  • $\begingroup$ Alright. I just printed something with 0 retraction so thats not the problem. I think you are right with the heatbreak.. Is the only solution to this to buy a new hotend with everything? (fan etc.) $\endgroup$
    – DonaldEnte
    Aug 28 '18 at 15:15
  • $\begingroup$ I have the same problem with pulling out the filament again. I will try printing at 190°C and redruced speed. $\endgroup$
    – DonaldEnte
    Aug 28 '18 at 15:21
  • $\begingroup$ No, the printer design is presumably not fundamentally flawed. Really this is about finding the exact problem and making a small change to fix it. $\endgroup$ Aug 28 '18 at 15:39
  • $\begingroup$ I just tried lowering the temperature. Sadly it didnt work. After a while under-extrusion and stop of extrusion.. But the filament was quite easy to pull out. $\endgroup$
    – DonaldEnte
    Aug 28 '18 at 16:31
  • $\begingroup$ Basically all of my prints right now are like the last picture. Do you have more ideas? I am starting to lose mine :/ $\endgroup$
    – DonaldEnte
    Aug 28 '18 at 19:24

Sadly, this isnt true: "I finally found the solution! It was the spring being slightly too loose at the feeder. That was it. Such a small thing. I thought that I checked it at least twice."

I bought a new Hotend for my 3D-Printer. I hope that solves the problem. I think that the PTFE Tube doesnt sit tightly on the nozzle so that some filament leaks through. And maybe the fan doesnt work properly. At least I can say that the problem is the Hotend. -the cooling of the filament I guess. Thats because the filament always became larger near the nozzle because it melted. That's also the reason why it was so hard to pull out.

  • $\begingroup$ Hi Donald, I have undeleted your answer, as it appears to be the actual solution. If you could mark it as the accepted answer, using the green tick icon, that would be great, as it will remove your question from the unanswered queue. Just out of interest, why did you delete it? $\endgroup$
    – Greenonline
    Sep 6 '18 at 17:00
  • $\begingroup$ I deleted it because sadly it didnt solve the problem. $\endgroup$
    – DonaldEnte
    Sep 7 '18 at 13:01
  • $\begingroup$ But this thread is quite messy now, so I ll create a new one. I bought a new hotend. I hope that fixes the problem. $\endgroup$
    – DonaldEnte
    Sep 7 '18 at 13:02

Fixed this by replacing the hotend.


A 0.27 mm layer height is not correct for any printer, any nozzle/hotend, any file, and should never be used as a layer height variable for any FDM printer.

Layer height should be a factor of the diameter of your nozzle size. i.e. Your nozzle is 0.4 mm, so depending on your printer, your range of resolutions/layer heights could start as low as 0.04 mm, but is monumentally more likely to begin at 0.08 or 0.12 mm, with a maximum value being 0.28 mm, and maybe 0.32 mm if you're doing some risky/experimental spiralized vase printing.

  • $\begingroup$ Hi! I would like to discuss with this a bit. I agree that the optimal layer height is related to nozzle diameter. But how would you support the theory of it being the factor of nozzle diameter? I would propose Flow Math article as a counterweight. $\endgroup$
    – octopus8
    Feb 4 at 5:40
  • $\begingroup$ That layer height could be poor selection also for some hardware setup. However the question was stated for Creality CR-10 printer, which (afaik) uses T8 threaded rods with 2 mm pitch. Then this layer height is OK even doing full steps for Z axis. Prusa calculator for Optimal layer height for your Z axis is very helpful here. (When using microstepping, even 0.2675 would be ok ;), but microstepping itself may introduce some inaccuracy. I disable it for Z axes.) $\endgroup$
    – octopus8
    Feb 4 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.