I have tried to print a 3D model with Creatr HS from Leapfrog. This print failed twice. The 3D model is the same, .gcode the same. Surprisingly it failed at different stage. Please look at the pictures. You can see the place where extruder was when print stopped.

Same model interrupted at diff. stage

I checked the filament and extruders, it is NOT a problem here. Extruders are not clogged, filament is not tangled nor blocked. Stepper motors stopped working, anyway the display shows that print progresses.

I have created a ticket for this issue on Leapfrog support page, but had an answer that this printer is no longer supported.
Does anyone has an idea what could be the core of the problem?
Today I have tried print again to observe and answer questions from the comments. Observations are:
- The process suddenly stops
- Hotend cools down (you can observe it on the picture below - I am using left extruder - as you can see it shows 24/0; 24 is actual hotend temp, 0 - wanted temperature )
- Display shows that print is progressing even faster than it would happen when everything is fine (maybe this is not important)

46 percent
49 percent


I have opened the printer to see what is happening inside. The electronics is divided into 2 PCBs. One is an 'heavy job workhorse' (drivers and some logics), the other is a Olimex A20-Olinuxino-Micro. The pendrive with .gcode is connected to this board as well as the display and control joystick (actually encoder). Olimex
One of the USB ports from Olinuxino is connected to 'workhorse' board. Next to the USB port here you can see Rx/Tx diodes.
When the print is in active state, two Rx/Tx diodes located on workhorse PCB blinking occasionally (mainly when there is a print head direction change), what brings the suggestion, that the data comes from Olinuxino PCB. When the print stops, these two diodes are blinking rapidly. I am thinking that there is some problem with Olimex board (it is sending uncontrolled data or data is being send too quick).
Below you can see image of drivers board with Rx/Tx diodes continuously on. There is also another Rx/Tx pair and these are also both on. Driver pcb Leapfrog
I'm going to do some search on Olinuxino board/system.

Finding: During board and temperature check I have found that the fan cooling bottom Olimex pcb is dead. I have took it out, connect to +24V and... no spinning.
Dead fan Creatr HS I have replaced the fan to a new one. Also, I have created a 20mm box model for printing, sliced it and tried to print it. No success here. After 2 lines of print sudden stop and Rx/Tx blink. I have downloaded model of Marvin, sliced it and tried to print: all ok!
Also I want to know if the data is continuously fetched from USB or loaded to Olinuxino and then used to print. So, started the Marvin print, removed USB from Creatr HS and yes, the print continues until the end. I am thinking that the data must be stored in Olimex memory and then fetched and fed to drivers PCB. Question is: where in Olimex the data is stored? Is lack of fan (and possibly overheat) damaged it slightly? If this is stored in onboard NAND memory it could cause a problem after a long time - it has 100 000 write/erase cycles.
NAND Kynix
New board would be a solution, unfortunately Leapfrog ran out of them. Olimex is selling boards, will try to buy one. I hope that different revision will work.

  • $\begingroup$ By 'stopped', I assume the print finished as expected, just with no extrusion? When you say 'not blocked', will another print work straight after? Is the hotend still hot? It's not clear what you say about steppers. Maybe the driver chip is overheating? $\endgroup$ Commented Sep 4, 2018 at 13:19
  • $\begingroup$ By 'stopped' I mean interrupted (without any external forces/actions). The head stops and stays in place. By stepper motors I mean X/Y/Z axis stepper motors. $\endgroup$
    – smajli
    Commented Sep 4, 2018 at 13:51
  • $\begingroup$ so the whole print job crashes? Is is just a print of this duration? Hot location? $\endgroup$ Commented Sep 4, 2018 at 14:08
  • $\begingroup$ I don't think so. I have successfully printed the same model when we had very hot days. Today it is around 19 degrees. $\endgroup$
    – smajli
    Commented Sep 4, 2018 at 14:45
  • $\begingroup$ Did you abort the print as it stopped or did you give it a minute? At times a print may halt if the heater block drops below a certain temperature... You should be able to monitor and log temperature via Repetier host just by connecting to the printer with a cable. Just let it print and watch the temperature curves - if it fails again, you might have ruled out temperature droßp or identified it as reason. $\endgroup$
    – Trish
    Commented Sep 4, 2018 at 15:08

1 Answer 1


I have solved the problem. After some investigation I have decided to connect directly to the drivers board. It needs to be disconnected from Olimex board and instead connected to the PC, then select 250kbps speed, COM port can be found through Device manager. I have used Repetier-Host in not Easy Mode and all possible messages turned on to see all possible messages. Then I prepared 20mm box to print and tried to print. After two lines voila! Error message:

12:35:32.401 : N187 M105*41
12:35:32.841 : Error:0
12:35:32.841 : : Extruder switched off. MINTEMP triggered !
12:35:32.924 : Error:Printer stopped due to errors.  
Fix the error and use M999 to restart!. (Temperature is reset. Set it before restarting)  

Now I went for quick search and learned that this can be caused by intermittent fault of thermistor or its wiring. Thermistor connection on Creatr HS So, I disconnected thermistor from the PCB and checked its resistance: 170kohm. Now, when I moved the extruders on X axis there was a particular position when thermistor resistance went to infinity. There is a connector in head which went loose. After refitting the printer is behaving correctly.
It is a shame, that the display on this machine does not present any feedback from the drivers board. Also, the PC connectivity on the rear of this printer does not bring any clear information (rear USB is first connected to the Olimex PCB and then to the drivers PCB, some information from drivers PCB are lost). BTW: Leapfrog drivers board is an Arduino based Marlin firmware. Info sent to serial connection after connectivity established is:

Leapfrog Firmware: 2.5  
Model: CreatrHS 
Extruder offset X: 15.23 Y: 0.02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .