I'm using a 3DTouch sensor (from Geeetech) on a self-build CoreXY printer (HyperCube Evolution). The sensor worked perfectly until not being used for a month.

The symptoms are that it fails to deploy the pin on the second probe deployment so basically it fails after the first probe is triggered by the raised platform.

On homing Z (not only for G28 or "home all" but also for G28 Z to "home Z axis") and goes into some sort of a fail-safe mode where the LED keeps flashing. Sometimes it does deploy and finishes the homing instructions and continues to the G29 instruction (note that double probing #define MULTIPLE_PROBING 2 is enabled in the Marlin 1.1.8 firmware) and show similar symptoms as described above for the G28 command. Note that failing to deploy the probe sometimes leads to a rising build platform that does not stop, other times some fail safe kicks in and the bed lowers and aborts the print.

To lift the fail-safe condition, a reset of the sensor is required (this can be done through the LCD or by command M280 P0 S160).

What I have done to solve the problem is to isolate the wires from the 3D touch sensor as I was under the impression that this was related to electromagnetic interference (therefore when the sensor is probing, the bed and heater cartridge are not powered momentarily), but that did not help.

Any suggestions and solutions to get it working again are appreciated.

  • $\begingroup$ Have you checked wire connectivity while moving the wires around? If the sensor wire for the probe (assuming a three wire setup), if the sensor wire (not power or ground wires to the probe) is failing at certain angles, it might give you something like you're stating. Yes, I'm grasping for straws. $\endgroup$ Sep 20, 2018 at 12:46
  • $\begingroup$ Any time I run into a "ran when parked" situation (old joke from used-car collectors), I suspect dirt, dust, grime leading to mechanical failures. See if there's any way to do a careful cleaning. $\endgroup$ Sep 20, 2018 at 15:24

1 Answer 1


After troubleshooting I have managed to fix the sensor problems.

(Please take note of the update at the end of the answer below as the problem started again shortly after the so-called fix...)

Digging into several posts I found this post that hints to a solution:

Instructions to adjust the 3DTouch sensor

After readjusting, the sensor worked and I was able to produce a print, but the next day it failed again... What I found is that the bed and extruder are NOT shut off while probing although that should have been enabled in Marlin 1.1.8. I assumed that this de-powering is only during the actual probe lowering, so very short. So I figured that this might be an EMI problem. In a last resort I updated to Marlin 1.1.9 which has the functionality to shut the power off for heater and bed and everything now seems to work perfectly. I now see that the de-powering is a bit longer and in fact the extruder temperature drops slightly, this has never been seen with the previous firmware version.

Not long after the "update"/"fix" the problem manifested itself again... Further troubleshooting revealed that it was a bad connection of the connectors of the sensor that got temporarily "fixed" as the cables had been fiddled with during the firmware update.

I have to note that the quality of these non-genuine sensors is not close the the original BLTouch. The BLTouch has never failed me to date, while several 3DTouch sensors did...


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .