3
$\begingroup$

So I've got a couple problems, to begin I'm using the RAMPs 1.4, generic Arduino mega with Marlin, generic stepper motor drivers, a generic power supply. Nothing is special or even out of the ordinary. But for some reason when I plug the RAMPs in, with everything connected or everything unplugged my Arduino heats up like hell. I clocked it at around 60°c after a couple seconds of being powered on around where the main chip is. The voltage regulator seems fine because it doesn't heat up much, I've checked it around 40°c.

Second problem is the stepper motor drivers keep blowing up for some reason. With everything plugged in I power on the board for the first time and hear a small pop and then a small amount of smoke comes from the extruder driver. I replaced it thinking it was just a bad chip and the same thing happens. All other chips are fine it's just the extruder that fries.

When the board is plugged into usb it doesn't give me any readings what so ever on what the printer is doing but the Arduino works fine with anything else I throw at it.

Things I've tried: - Lower the voltage on the power supply from 12.00v to 11.26 with no changes - try running it with everything plugged in and everything unplugged - tried buying a new Arduino but the exact same problems occur

I've gotten kinda tired of thinking of ways to trouble shoot so I'll open it up to the community. Picture of a friend stepper driver

$\endgroup$
  • $\begingroup$ can you post more images of your ramps board.Does you try to change your ramps board.Check your ramps board for any short circuit. $\endgroup$ – Himanshu Sep 21 '18 at 6:21
  • $\begingroup$ Welcome to 3D Printing! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Sep 21 '18 at 12:24
  • $\begingroup$ Himanshu: here's a pic of the RAMPs photos.app.goo.gl/y9WsRNbMXzEE2iTRA $\endgroup$ – Broken Buildings Sep 21 '18 at 13:20
  • $\begingroup$ I suggest you to check with another ramps board. $\endgroup$ – Himanshu Sep 22 '18 at 2:14
1
$\begingroup$

This really sounds like there is a short somewhere on the RAMPS add-on board. It is advised to not use the RAMPS add-on shield to prevent damage to the Arduino or the shield.

Personally, I would ditch this one and buy a new one. By the looks of the picture you are using a clone RAMPS, these are mass produced and the quality is not always the best (many components are skew). If you are very into electronics you could try to find the short, but it can well be that the traces on the board are somehow connected. Alternatively, you could buy a new board where RAMPS and Arduino are already combined, e.g. an MKS board.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ I totally agree with the short suggestion, often they are caused by the user (poor soldering or cable residues). Maybe highlight to OP that he totally shouldn't use the printer without observation until this is solved. $\endgroup$ – dgrat Sep 27 '18 at 7:46
  • $\begingroup$ @dgrat Thanks for the addition, I have updated the answer. $\endgroup$ – 0scar Sep 27 '18 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.