5
$\begingroup$

I have enabled auto bed leveling on my 3D printer. I have used a 6-36 V inductive sensor with a 7805 voltage regulator running the sensor at 10.78 V.

I am using Marlin 1.1.9. This is my configuration file for Marlin firmware. I used this video for marlin setup.

I have done a voltage regulator setup by using this video.

I have place an Aluminium plate with insulated copper wire. (I also tried an Iron plate). After Setting this I use Pronterface to control the printer. While homing command is given the XY axis gets home and Z axis moves downwards and doesn't stops even the Light in the sensor gets ON. This video I made shows that it does not stop.

And also once the Zmin gets TRIGGERED, it is always TRIGGERED.

After I enabled SAFE_HOMING, the XY axis comes to the centre of the printer. And Z axis goes down again without stopping.

Please help me in this.

$\endgroup$
  • $\begingroup$ Problem solved. Just downgraded the marlin version to 1.1.0 and done the same changes. Now it works. Thanks for your suggestions @Oscar $\endgroup$ – Baalaji V Oct 1 '18 at 15:24
  • $\begingroup$ Please look into this answer, it explains the necessary steps to enable ABL. Maybe it is better if you start with a fresh configuration.h file. $\endgroup$ – 0scar Oct 3 '18 at 8:38
  • 1
    $\begingroup$ It is advised to use the latest firmware version 1.1.9. With the answer below and this anser you should be able to get it running in 1.1.9. If so accept the answer, if not, please add your own answer and accept that after 48 hours. A downgrade of firmware does seem like a quick fix, better said work-around, but not an actual solution. $\endgroup$ – 0scar Oct 3 '18 at 8:42
  • $\begingroup$ Hi, I see that your original question has been answered. If you have additional follow up questions, then please post them as separate questions and not as comments as these are not searchable and will not be as useful to other people who may have the same issues. Please feel free to ask as many questions as you like, but just post them as new questions, rather than comments. You can always refer back to this (or other) question's URL in your new question, if you feel that they are related. If they are clarifications to your original question then please edit it and add them there. Thanks $\endgroup$ – Greenonline Oct 3 '18 at 10:31
  • $\begingroup$ As this is a Q&A site, and not a forum, unfortunately it is not possible to ask user to share config files. There is no central repository to share them to, and the config file would be too large to post in its entirety in an answer. Direct correspondence between users (outside of comments and answers) is also not allowed, I'm afraid. Apologies and I hope that you understand. $\endgroup$ – Greenonline Oct 4 '18 at 9:17
4
$\begingroup$

Your problem is that the hotend carriage does not stop when the sensor triggers. I assume you mean "on homing", not "while printing" (UPDATE: after watching the video it is confirmed that it is "on homing"). First, the working and this difference is explained. Thereafter your configuration file is assessed and typical errors or inconsistencies are reported. Note that assassing an existing configuration file is more work than for you to start over taking the consideration below into account. Also look into this answer which describes what you need to do starting from a clean configuration file.


Note:
Why not test if the sensor works at higher Z values by using a metal screwdriver to test if the head stops, then you do not run into the bed (with way less change to damage your printer). From the video you can see that the sensor triggers, does the signal also gets registered by the printer board? With M119 you test the endstop status of all endstops.


Auto bed leveling theory
An auto level sensor does not trigger exactly when the nozzle hits the bed like in normal leveling using switches. The sensor is meant to detect the bed before the nozzle touches the bed. It is the offset that you define with command M851 e.g. M851 Z-1.85 that determines the correct offset between sensor trigger point and the nozzle. After homing G28 and auto bed leveling G29, the nozzle needs to get under the sensor trigger point (e.g. in the example above it is then still 1.85 mm away from the platform) so while printing it is perfectly fine that the sensor stays triggered until printing height gets above 1.85 mm. This gives an answer why you see the head go past the trigger point when printing, when homing or leveling that should not happen.

Configuration file observations
From your configuration can be seen that

//#define Z_SAFE_HOMING

is not enabled, this is advised to enable. This is important, but not the complete solution.

Also, you have not defined the auto leveling area by setting the boundaries for probing (where the probe can reach). In your config you will find disabled constants for (see also this answer):

//#define LEFT_PROBE_BED_POSITION MIN_PROBE_EDGE
//#define RIGHT_PROBE_BED_POSITION (X_BED_SIZE - MIN_PROBE_EDGE)
//#define FRONT_PROBE_BED_POSITION MIN_PROBE_EDGE
//#define BACK_PROBE_BED_POSITION (Y_BED_SIZE - MIN_PROBE_EDGE)

You only have defined a Y sensor offset in your configuration :

#define Y_PROBE_OFFSET_FROM_EXTRUDER 43 

but the video and the comments say otherwise, you should therefore should have set:

#define X_PROBE_OFFSET_FROM_EXTRUDER 43 

so e.g. the following could work (depending on the offset from limit switch position to printer origin):

#define LEFT_PROBE_BED_POSITION MIN_PROBE_EDGE
#define RIGHT_PROBE_BED_POSITION (X_BED_SIZE - MIN_PROBE_EDGE)
#define FRONT_PROBE_BED_POSITION MIN_PROBE_EDGE + Y_PROBE_OFFSET_FROM_EXTRUDER
#define BACK_PROBE_BED_POSITION (Y_BED_SIZE - MIN_PROBE_EDGE)

Another part in your configuration that need further inspection is your offset from limit switch position (when homing) to printer origin; you have:

#define X_MIN_POS 0
#define Y_MIN_POS 0

This is very unlikely, but possible, it means as is that the X=0 and Y=0 is exactly on the limit switches for X and Y. Usually this is not the case and you see negative values for these constants.

All-in-all, your configuration file has a lot of problems which need to be fixed. To solve your problem you need to read into configuring Marlin. Once you got the printer working fine you progress to an ABL sensor and make the correct settings in the configuration by using the hints above.

$\endgroup$
  • $\begingroup$ As I have placed the proximity sensor in right side, think so don't need to change in printer origin position. Please do me a kind favor, If possible will you change some settings in my configuration.h file which is needed for Auto bed leveling and send it to me. I will check it and report it to you. I will be thankful to you if you do so. $\endgroup$ – Baalaji V Oct 1 '18 at 11:02
  • $\begingroup$ I have placed the sensor in right side and it is aligned to be straight with nozzle's tip. So I set 0 for X probe offset. $\endgroup$ – Baalaji V Oct 1 '18 at 11:19
  • $\begingroup$ Not right side (in config that is), you have configured it at the back: #define Y_PROBE_OFFSET_FROM_EXTRUDER 43 furthermore, I would like to help, but I do not know what printer you have nor do I have access to it, I simply can't. Please beware that this is not a forum, we answer the questions of people that post them. I have posted the errors I found in your config, please address them and see what happens. The problem you face is a printer configuration issue. Please post your printer brand and type. Also add a picture to the question. $\endgroup$ – 0scar Oct 1 '18 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.