7
$\begingroup$

One of the local libraries has a new small Makerbot 3D printer. I have been submitting Sketchup files converted to STL files for printing.

The tech guy who runs the printer for patrons is having trouble getting a project of mine to come out to be the right size. I need this item go be 2 inches wide. The tech guy sizes the item on the screen to 2 inches. I watched him do it. But, the item is printed with a base of 2 inches, and the item itself comes out smaller.

Does anyone have suggestions about this? I can get more info if someone can give me the right questions to ask. The tech is open to taking suggestions. He wants to get the printer running smoothly for patrons.

I submitted a file with my own base with supports made in Sketchup. But, the tech guy said he needs to set the printer to create it's own base and supports.

Additional info:

When I printed it by letting Makerbot create the base and supports, it came out to be 1 3/4" as shown here: https://flic.kr/p/EashnD

Printer: Makerbot Replicator with Smart Extruder (not Plus). (I am now at the library with the technician.)

Here is a screenshot of what I am trying to print. It is a replacement clip for a messenger bag. So, it has to be 2 inches across. https://flic.kr/p/EtdM6s

Here is the printer: https://flic.kr/p/E5F1M6

I used a website to convert the DAE file exported from Sketchup to an STL file. It was GreenToken.com.

If I open the object's STL file in Tinkercad, the object appears two inches wide. And, if I open the file in one of the 3D printer websites in Tinkercad, the object appears two inches wide (in cm).

The security on the library's computers do not allow me to apply plug-ins to Sketchup. The library's Tech staff is going to eventually put the plug-in in there.

If it is resized to 2 inches wide in the MakerBot software to be sent to the printer, why is it printing the generated base 2 inches wide and not the object? Are there some settings the tech guy in the library is missing in this set up window?

Additional notes: The library now has the latest version of SketchUp on Macs. They are working on installing the STL plugin. (Security issues)

My process for producing an STL file to print is now this:

  1. I create something in SU and export it as a DAE file.

  2. I have found that meshconverter.com produces better STL files than greentoken.

  3. I then upload/fix the STL file at the netFabb website.

  4. I then import the STL file into TinkerCad to view it. If there are problems in the file, I can see them. And, I run it through netFabb again. I can also modify the file in TinkerCad. It is no where near as sophisticated as SketchUp. But, it doesn't claim to be.

I have found that there is a way to export the STL file to 3D printer hubs through TinkerCad. You can see the prices, the material available and the location of the company/person doing the printing. You can contact the printer ahead of time and they can look at your file to give you advice.

Update

I just wanted to add that the netFabb website does not export STL files after it fixes them. It now gives you a 3MF file format when you upload an STL file. I am not sure why this happens. But, this has put a big wrench in my process. I can no longer fix SketchUp STL files with netFabb. When I bring them into TinkerCad, I see errors in the object. It seems like there are issues with complex curves.

$\endgroup$
  • $\begingroup$ How far off are the dimensions? Which Makerbot printer is this? $\endgroup$ – Ryan Carlyle Mar 8 '16 at 19:20
  • $\begingroup$ Also, can you upload a render of your model? $\endgroup$ – tbm0115 Mar 8 '16 at 19:39
  • $\begingroup$ What are you using to do the export to STL I use this with great success github.com/SketchUp/sketchup-stl $\endgroup$ – Kevin Morse Mar 9 '16 at 3:08
  • $\begingroup$ I'd second KevinMorse 's suggestion with using the Sketchup-STL pluggin. I've used it for years now with a MakerBot Replicator (1st gen). The trick with sketchup is making sure the right units are output. The pluggin mentioned above allows you to specify the units regardless of the SketchUp template. When you export using this pluggin, select the output in metric millimeters to have everything jive with MakerWare/MakerBot Desktop (MakerBot's slicing engine). Let us know if this helps. $\endgroup$ – tbm0115 Mar 9 '16 at 16:51
  • $\begingroup$ tbm0115 and Kevin: Thank you very much for this. As things develop, I will add to this post. $\endgroup$ – user706 Mar 9 '16 at 23:55
1
$\begingroup$

It appears that you have scaled the object after the raft and supports were added. As you can see in your photo of the raft, the clip is approximately 7/8ths (1.75/2) the size of the raft.

Edit: As a side note, STL files don't actually have a concept of units. Each axis is defined in arbitrary units. That's why when you export and import it you have to set the scale appropriately.

| improve this answer | |
$\endgroup$
  • $\begingroup$ ArkTekniK; Thanks. I can tell you that the tech guy at the library opened the file in the Makerbot software, selected the object, brought up a menu that allowed him to size it by entering numbers and selecting either mm or cm. He then added the raft and supports somehow when I wasn't there. $\endgroup$ – user706 Mar 9 '16 at 23:59
1
$\begingroup$

When exporting from SketchUp you have options for what units you want to export the STL as. Pronterface and Slic3r use millimetres so for these you should export as millimetres.

You can run into issues when designing a part in inches and then pulling it into printer software which might be expecting millimetres. In this case you may have to scale the part by 25.4 in all three axes.

As an example, if you have a 1" test cube and you export it as mm the STL will have six faces that look like this

facet normal -1.0 0.0 0.0
  outer loop
    vertex 0.0 25.4 25.4
    vertex 0.0 0.0 0.0
    vertex 0.0 0.0 25.4
  endloop
endfacet

You can see there are no units anywhere. If you import this into a program that is expecting inches you will get a test cube that is 25.4 inches cubed. Scaling by 25.4 can fix this OR you can just tell SketchUp to export as inches.

| improve this answer | |
$\endgroup$
1
$\begingroup$

I´m using sketchup 8 and I had the same error under makerbot, and some times with slic3r. After testing some programs to fix mesh I realize that some faces are inverted on STL file, so this can be detected on preview under pronterface, or simplify3D. before sending to print is needed to check this point; not all STL from a repository is working or is with the right size. If you detect a GRAY surface is time to invert that face to get que correct fill.

| improve this answer | |
$\endgroup$
0
$\begingroup$

My advice is to use a micrometer (i.e., sliding dial caliper) accurate to within .001" and measure the printed object. If it is 1 7/8" for example, you would open the STL file in Makerbot software and use their scaling tool to scale the object to 1.0666666...., which is what you get when you divide the desired size (2") by the actual printed size (1.875"). I have found that it is much simpler to do that than to reinvent the wheel and try to figure out what each software engineer was thinking on each program and each conversion process and try to make it work right every time. Chances are that the same conversion factor might work right for any file originating from the same source and going through the same conversion software package. Also, 3D printers in general don't like edges that aren't completely "welded", or continuous seams. With Sketchup if you keep zooming in on an edge you almost always get seams that are stitched at intervals determined by Sketchup algorithms. They are "unwelded" seams. Some 3D printers can handle them. Many don't. I have used various 3D software packages, including Sketchup, and the best one so far has been Rhinoceros 3D. It handles multiple complex curvaceous planes and can radius adjoining curved edges and can "weld" them. Aeronautical and boat building companies use it for CAD/CAM applications.
... The STL file converter you mentioned is probably taking the Sketchup file and "cleaning it up" so Makerbot likes it. You would almost have to know exactly what algorithms each developer uses. to try and 'fix' it mathematically Like I said, do your own measuring and scale accordingly. BTW, it's better in my opinion to let Makerbot do the rafts and supports. Their engineers typically do a pretty good job. Where I have had issues is on things with a shallow angle (almost horizontal) hanging out into empty space. If you can re-orient the object in the makerbot software so those types of angles are minimized, the print is alot cleaner.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Makerbot automatically puts in rafts, and supports at preset intervals so the plastic won't sag. You can override Makerbot automatic settings, but I don't recommend it until you've printed dozens, or even hundreds of objects. If you're not confident that you know more than the designer of the Makerbot printer, leave the rafts and supports up to the engineers. The Library tech aide doesn't have the skillset to change the raft and support presets. I have messed with them and ended up with piles of stringy plastic on the rafts. I have had some success, but Makerbot algorithms are superior. $\endgroup$ – Dave Nov 15 '17 at 5:55
  • 1
    $\begingroup$ A "sliding dial caliper" is not a micrometer. $\endgroup$ – Tom van der Zanden Nov 15 '17 at 9:26
  • $\begingroup$ Not true, technically. All micrometers fall in the family of 'calipers' merriam-webster.com/dictionary/micrometer .Most dial, digital and verniers are technically "not" micrometers, because a "micrometer" is one millionth of a meter. $\endgroup$ – Dave Nov 16 '17 at 18:43
  • $\begingroup$ For the purposes of this thread, any relatively inexpensive caliper, either digital, dial or vernier (including the barrel and "C" clamp style micrometer), would be more than sufficient to get the accuracy desired. $\endgroup$ – Dave Nov 16 '17 at 19:19
  • $\begingroup$ Not endorsing these products. These are inferior quality and wouldn't work in most machine shops, but for this thread, any of these would work if used and taken care of properly: harborfreight.com/catalogsearch/result/index/… $\endgroup$ – Dave Nov 16 '17 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy